Mail issues - outbound email are sent from virtualmin hostname's IP instead of the domain's IP


I created a new Virtualmin server and added 2 virtual servers.

I have started to notice that some emails (from both virtual servers) are not sent and they stay in the queue (the message I see is this "message: Client host rejected: cannot find your reverse hostname (here is the virtualmin IP, not the domain IP).

Both virtual servers have their own IP address and reverse DNS is set up correctly by the ISP.

I see that the issue is that the email is not sent from the virtual server IP but from the
Virtualmin IP. Therefore, the Virtualmin IP is not reverse resolved to the virtual server domain.

I tried to change webmin/servers/postfix mail server/what domain to use in outbound mail to “use domain name” instead of using hostname but I got bounced back emails with “ (expanded from user@domain1.como): User unknown in virtual alias table”.

Can you please help to resolve this issue?
For example, no emails that are sent to are leaving the queue.

Thank you

Also, I got the same message for other email providers - Client host rejected: cannot find your reverse hostname, [here is the virtualmin IP instead of the virtual server IP which has the correct reverse DNS setup] (in reply to RCPT TO command)…


Try checking an option ** Send outgoing email for domain from IP** under Email Settings.

PTR is something that has to be setup on ISP side. You can test if it works correctly by running:


Hi, Ilia,

Thank you for pointing me to that settings.

I followed your recommendation and I see that some emails that were hanging in the queue are now sent.

Thank you very much for you help!

Stay safe!

1 Like

Thank you for kind wises - you stay safe too!

Hi, Ilia,

Again me :slight_smile:
I hope everything is fine with you and your family.

I am still seeing emails in the postfix queue and error messages in the mail log - “Client host rejected: cannot find your reverse hostname, [shared IP = server IP] (in reply to RCPT TO command)”.

In the header of an email that I sent to an yahoo recipient I see that EHLO is set to server’s hostname (not to the virtual domain fqdn =
So, no matter how many domains/virtual servers I am hosting on this virtualmin server, the emails sent from any domain have EHLO set to the server’s hostname.

Please let me know if there is other configuration that I can change to fix this issue (apart from changing “Send outgoing email for domain from IP” to “Virtual server’s address” which I did).

Thank you

I forgot to mention that the domain IP has a PTR record for added by my ISP, I checked it and it is resolved correctly.

Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.