Mail issue on fresh el8.2 install

I did a clean install on el8.2. After I insert my email information, Thunderbird says incorrect settings. When I log into Usermin with my email credentials and send a test email to my gmail account, this is what maillog reports:

Aug 20 07:37:18 dev postfix/smtpd[2375]: warning: unknown[x.x.x.x]: SASL LOGIN authentication failed: authentication failure
Aug 20 07:37:18 dev postfix/smtpd[2375]: disconnect from unknown[x.x.x.x] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Aug 20 07:37:29 dev postfix/smtpd[2375]: connect from fqdn.mydomain.com[127.0.0.1]
Aug 20 07:37:29 dev postfix/smtpd[2375]: 59C995438CC1: client=fqdn.mydomain.com[127.0.0.1]
Aug 20 07:37:29 dev postfix/cleanup[2417]: 59C995438CC1: message-id=1597909049.2413@mydomain.com
Aug 20 07:37:29 dev postfix/qmgr[1449]: 59C995438CC1: from=user@mydomain.com, size=650, nrcpt=1 (queue active)
Aug 20 07:37:29 dev postfix/smtpd[2375]: disconnect from fqdn.mydomain.com[127.0.0.1] helo=1 mail=1 rcpt=1 data=1 quit=1 commands=5
Aug 20 07:37:31 dev postfix/smtp[2418]: connect to gmail-smtp-in.l.google.com[2607:f8b0:400e:c08::1b]:25: Network is unreachable
Aug 20 07:37:31 dev postfix/smtp[2418]: 59C995438CC1: to=myusername@gmail.com, relay=gmail-smtp-in.l.google.com[x.x.x.x]:25, delay=2.2, delays=0.05/0.03/1.7/0.34, dsn=2.0.0, status=sent (250 2.0.0 OK 1597909051 k14si844956pfp.7 - gsmtp)
Aug 20 07:37:31 dev postfix/qmgr[1449]: 59C995438CC1: removed

I feel like this means that maybe Webmin/Usermin has an incorrect password stored for my user some how?

Also saw this in maillog as well:

Aug 20 07:42:39 dev postfix/smtpd[3222]: warning: TLS library problem: error:1408F10B:SSL routines:ssl3_get_record:wrong version number:ssl/record/ssl3_record.c:332:

Any direction would be helpful, thank you.

Do you have port 25 open on your server / firewall. Does your VPS host permit you to use port 25?

Firewalld is allowing the smtp and smtpd service. I’m new to Firewalld but I believe services added open up their correlating ports, 25/tcp and 465/tcp. I’m on Digital Ocean, shouldn’t be an issue there.

firewall-cmd --list-all
public (active)
target: default
icmp-block-inversion: no
interfaces: eth0
sources:
services: cockpit dhcpv6-client ftp http https imap imaps pop3 pop3s smtp smtps ssh
ports: 587/tcp 53/tcp 20/tcp 2222/tcp 10000-10100/tcp 20000/tcp 1025-65535/tcp 53/udp
protocols:
masquerade: no
forward-ports:
source-ports:
icmp-blocks:
rich rules:

Well, I am not sure Digital Ocean keeps port 25 open by default. See https://www.digitalocean.com/community/questions/port-25-465-is-blocked-how-can-i-enable-it

I should have used telnet to check if the port was open, great info, thank you. I wouldn’t have thought they would have done that. Barring using MailGun or a similar service, might I just force everything through port 465, or will this eventually cause problems?

Thanks for the wisdom.

Glad I could be of help, @tommyvirtualmin. No, using port 465 will not solve the problem. But this might:

Free smarthost / mail relay to work around port 25 block by VPS host

Update: Looks like my Digital Ocean account had port 25 opened I learned when I emailed their support team (my account is older than 6 months, apparently that is their requirement). It looks like when I ran telnet against port 25 on my server it was my ISP (Spectrum) blocking it, not my web server.

So I ended up going into Webmin -> Servers -> Dovecot IMAP/POP3 -> Networking & Protocols -> Accept SSL Connections -> and switched “default” to “Yes” and now my email is working perfectly. No more errors in ‘/var/log/maillog’.

Thanks for the insight, @calport. Very nifty solution you implemented as well on your Virtualmin instance, btw. Pretty cool.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.