Mail from users to virtualmin users has an incorrect Reply-to field.

I’ve searched the forums for a solution but my installation doesn’t seem to match the ones the solutions cover. For instance in one case the solution involved going to module configuration->mail … but I never found a module configuration option in virtualmin. Note, this is going from memory so the actual solution might have said modconf or moduleconf or modconfiguration, I just don’t recall.

Anyway I have virtualmin running a site that houses web sites for two connected clubs/organizations. Since one has no method of funding, the other graciously gave them space. (THat’s just for background).

When a user sends email to, the mail is forwarded to the presidents email address with a Reply-to set to my email address. I can’t figure out how to change this behavior. The From field is correct, i. e. it shows the actual sender. It’s not going to do the president a lot of good to reply to me. :wink:

I saw some solutions that involved postfix, but when I searched /etc/postfix/* for the reply-to string I didn’t see it, besides, I don’t think postfix has any idea what my email address is.

I’m running 3.80.gpl GPL on Centos 5.4 with postfix.

Oh and another solution involved usermin and setting the forward options, but there weren’t any filters defined.


Mmh, a first step in finding where this issue is coming from might be grepping through all config files in /etc for the email address that’s being placed in the Reply-To… It’s not guaranteed to succeed, but if some filter is at work or if it is some config option that replaces or inserts the Reply-To, the email address might appear somewhere there. Some config files can be found in /var/lib too.

At least that’s what I often do when I’m stumped as to where some odd behavior is coming from. :slight_smile: