Mail forwarding settings

Hi all,

Sorry, but I don’t know if this is a bug or simply it’s not possible. When I disable the primary email address for a user (we want to use another address & canonical maps) the “Mail forwarding settings” is disabled and it’s not available if you edit this email account.
Is that correct?

Thanks in advance.


Yeah, unfortunately, email for that user would have to be enabled in order to be able to setup forwarding.

The best I can offer there is that you could forward the mail elsewhere, and disable local delivery for that particular user. That’s configurable within that Mail Forwarding screen.


Thanks Eric,

But, If I enable primary email address, the canonical map is not used and the outgoing mails (including autoreplies) will have the username@domain.tld email address.

I thought that you need to disable primary email address to use canonical map and this action not produce others parallels results: but If I enable it, create an autoreply and after that, disable it again, it doesn’t work like it was expected, the autoreply is sended but the email address is composed with the user’s real name (not the username or the name at canonical map) and the virtualmin host domain not with the user’s virtual domain.

Another little problem ocurrs if you change anything of this user account with the primary email address disabled and previusly enabled autoreply. In that situation, the autoreply is lost.

Thanks again for your patience.