Mail Error, user not found

Having the strangest mail error.

have 3 domains on Virtualmin, one is working perfect.
The third, I cannot get the created user to be picked up or found.
it seems to be creating the user from the first domain or something.

it created the user, let me select options but It does not pickup any mail, mailbox is always empty.
It does let me send the mail out.

The logs say this :

ec 29 19:20:25 sv1 postfix/local[27893]: 21D8B2F80C6F:,, relay=local, delay=1.1, delays=1/0/0/0.09, dsn=5.1.1, status=bounced (unknown user: “user1.domain3”)

and it bounces with errors:

This is the mail system at host

I’m sorry to have to inform you that your message could not
be delivered to one or more recipients. It’s attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

               The mail system (expanded from unknown user:

Final-Recipient: rfc822;
Original-Recipient: rfc822;
Action: failed
Status: 5.1.1
Diagnostic-Code: X-Postfix; unknown user: “user1.domain3”

it seems like the final user should be at the domain 3 not the domain 1(hostname)

could it be caused by only the one hostname in /etc/hosts? The lines cannot be correct, it should be <user1.domain3@??DOMAIN3.COM???>

The mapping seemed to create these users as

im so confused, any help would be greatly appreciated.


Hmm, what about the second domain that you have… does email to those users work properly?

Also, regarding the user listed above that’s not working – if you go into Edit Users -> USERNAME -> Email Settings, is “Primary email address enabled?” set to “Yes”?

Lastly – are you able to log in as this particular user using an email client like Outlook/Thunderbird, or perhaps RoundCube?


q1 the other domain does work, the users work fine.

q2 it is set to enabled.

q3 I am trying to log in with thunderbird. Weird thing is that thunderbird thinks it is logged into the user but the mail never arrives. in Virtualmin, users, username, it even shows Last email login
SMTP (sending email) 28/Dec/2014 19:35
IMAP (fetching email) 29/Dec/2014 20:39

but the bounces persist, log shows no user and the mail never shows up.

it does however forward it if I put an address in the forward spot.

the key thing that is getting me is the reference back to

so the setup is (Default IP) 2 virtual servers 1 main 1 sub (working ), hostname in DNS is (Private IP) (working) (Private IP) NOT working (Private IP) (working)

im even getting a login in the logs from thunderbird

Dec 29 21:03:00 sv1 dovecot: imap-login: Login: user=user1.domain3, method=PLAIN, rip=xx.xx.xx19, lip=xx.xx.xx.19, mpid=13246, TLS


Before I forget (again), I wanted to mention that it’s normal to deliver messages using USERNAME@HOSTNAME, which in your case is " ".

The key is that the hostname would need to be listed in the “mydestination” line in /etc/postfix/

Since the other domains do work, I suspect it is, though it wouldn’t hurt to double-check that.

Seeing that you can login as user1.domain3 using Thunderbird, that certainly suggests that the user is there and working properly. We just need to sort out why Postfix doesn’t think that’s the case.

One other thing to try might be to run this command, and make sure nothing unusual shows up:

grep user1.domain3 /etc/postfix/virtual

Hi, and thank you for helping.

The /etc/postfix/ has this : is this correct? it must not be cause its not working on the one domain.

#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain
#mydestination = $myhostname, localhost.$mydomain, localhost, $mydomain,

mail.$mydomain, www.$mydomain, ftp.$mydomain

and the output of grep returns a blank line with nothing. I tried it a couple of ways.

root@sv1 /var/log: grep /etc/postfix/virtual
root@sv1 /var/log: grep user1.sv1.domain1 /etc/postfix/virtual

both produced nothing.

Hi Andrew.

So After tail -f maillog I was seeing some weird spam being sent off of the server, I went and deleted all of the mail for this user and all of the users with mail.

Still not sure if this is a cert problem or another type, and I’m going to recreate those email boxes and try again.

I am getting some strange SMTP connections so Im going to diag that.

Right now, I have another domain that will not receive any port 25.
Gmail bounces with port 25 socket error

The recipient server did not accept our requests to connect. Learn more at
[(1) []:25: socket error]
[(5) []:25: socket error]
[(10) []:25: socket error]

the domains below are receiving and sending mail on port 25, but if I wanted to

netstat -an | grep :25
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0 ESTA

add port 25 to another ip (the failing one, .19), would that be in the network adaptor settings of this
domain ip?



Is it just Gmail where you’re experiencing this problem with email delivery? Do other mail servers successfully deliver email to your server?

Actually, I attempted connecting to port 25 on the IP addresses mentioned above, and I don’t seem to be able to. Does your provider allow connections to port 25? Some providers block that particular port.


No, another domain hosted on this server is working receiving gmail to it.


.18 works to and from gmail or any other service in and out
.19 does not to and from gmail or any other mail service in or out

I listed above the output of grep on port 25, and it seems that 2 of the ips have a listing, but the ip in question does not. Does that give any clues?