mail elsewhere

This ones been bugging me for a while, and I’m sure there’s a solution, but I would rather not experiment on a system in use… I’m on VirtualMin GPL - it’s up to date.

I have email and my domain on my server. I also keep a friend’s website on my server. But his email is elsewhere. When I go to email him, the message is rejected as the server tries to put the message on the local host where the mailbox does not exist. How do I tell it to do a regular MX lookup and send the mail where it belongs? Just change the DNS server to ignore local DNS and use Global?



You can do that by going into Edit Virtual Server, and disabling the Mail for Domain feature for that particular domain. Once you disable that feature, Postfix will no longer think email for that domain is done locally.