Mail and FTP Users

If i create new mail user for domain, lets ay domain “

I set user Email addres to

.> okay, user is created, but email doesnt work, but works. Why it has to be ***** , why not ****


Whenever your email user authenticates, you would need to login as that user’s username – you can see what the username is by looking at the “IMAP / POP3 / FTP login” column after clicking “Edit Users”.

Usernames are in the format “user.domain” by default. If you wish to change that default, you can do so by going into System Settings -> Server Templates -> Default -> Mail for Domain, and change the “Format for usernames that include domain” field to your desired format.


I dont have such option under that path “System Settings -> Server Templates -> Default ->”

And login name is okay eather way, but why user has to use email adress , when is set to

I can see the option at the button of that “Mail for Domain” setting (did you see the dropdown list?).

By the way, from virtualmin’s help:

The username@domain option is not recommended unless you are migrating users from another system that already uses it. The Postfix mail server has problems with SMTP authentication by users with an @ in the username, and requires that an extra Unix user be created for each mailbox for mail delivery to work.

Aaah, didnt see that dropdown. Too tired, lol. Thank you!