mail aliases from 1 virtual domain to another not working.

I’m having a problem with setting up a mail aliases from 1 domain and having it go to an email on another domain (same server).


Main email:

Mail aliases:

I do not get any emails in “” when it’s sent to “”. I’ve searched the logs (/var/log/maillog) and it doesn’t have anything in there saying what happened (it’s like it doesn’t even know about it).

If I had a mail alias “” going to “” then I get the emails.

In usermin->postfix->virtual domains I see:

I’ve set these up in virtualmin.

2 Virtual servers, “” and “

I’ve tried using “Edit Mail Aliases” in to forward to and I’ve also tried going into “Edit Users” in and putting in the “Additional email addresses” box.

Any suggestions on what I’m doing wrong and how to fix it? I don’t have any more information (can’t find any logs saying what the issue is).

ok, I got a “Delivery Status Notification (Delay)” back a day later.

The error is “DNS Error: DNS server returned general failure”. I don’t understand why it would be a “DNS failure”, if I create an actual mailbox (instead of an alias) on “” and send a test email, I get it.


When creating the Virtual Server as an alias – can you verify that the DNS feature for that alias is enabled?

If for some reason that weren’t enabled, that could cause a DNS failure.


Virtualmin -> Edit Virtual Server -> DNS domain enabled? Yes

Is that the feature your referring to? Or is there somewhere in webmin to check?