mail alias problem

I set up a domain on my server (its still hosted somewhere else) with intention to move domain to new server
I set up email accounts too

when I email the domain through the server of course it gets picked up by this server and not the real server hosted elsewhere.

I wanted to stop this happening so rename the Virtual Server
however, the email is still not getting through this server. I checked the postfix file and found some entries so deleted them and rstarted postfix. email is still disappearing through server.

anybody any ideas what I can look for


I suppose we need more info about this to venture a guess… What’s the domain in question, before and after the rename? What address are you trying to email?

What gets logged to /var/log/mail.log at the moment you send an email?

What’s the contents of /etc/postfix/virtual?

the domain is
I renamed it (which doesn’t exist on my new server)

I haven’t seen anything in the logs to suggest there is a problem (emails don’t arrive)

I will check out again when i get home

I have investigated more and run the following

postmap virtual

I think it seems to have worked, but am waiting for user to get back to me and confirm.


Okay, so the problem seems to have rested in Postfix’ virtual domain mapping, as I suspected.

When you renamed the domain, supposedly using Server Configuration -> Change Domain Name, did you set “Change mailbox name suffix” correctly? I just tested that, and when set to “Automatically chosen” or “Change to”, it will rename local user mailbox names as well as the domain. When set as “Leave as”, it will leave email addresses untouched.

So either you forgot to set that option, or your situation is different than what I tested, or you found a bug. :slight_smile:

In any case, it’s generally not a good idea to just go and manually delete entries from server configuration files, at least as long as you don’t know precisely how they are integrated and managed from Virtualmin. Doing that can break things really good. :slight_smile:

this has come back to haunt me again :o(

I now moved the server back onto the server
some email accounts are working and some are not.
for example is not working

what should I check ? the aliases file ?

cheers Brian

the problem I think boiled down to a bad user, who didn’t set up properly (not using the domain name in the alias).