magento install fail on install scripts

the magento install seems to fail. I installed same on one server several months ago and it worked fine.
and tried to setup again yesterday and today, I tried on two servers.
says ‘subdirectory magento’ not found. I tried installaing on root and magento folder but both give same merror

but it does exist:
drwxr-xr-x 2 dunnabiefarmshop dunnabiefarmshop 4096 Sep 18 09:18 magento

not that I wanted it in a subfolder magento, as I wanted in root. which I had selected.
is this a magento problem for version or a virtulamin install script problem.

thanks for any advice Brian

Operating system CentOS Linux 6.9
Webmin version 1.852
Virtualmin version 6.00
Cloudmin version 9.3
Kernel and CPU Linux 2.6.32-696.3.2.el6.x86_64 on x86_64

Operating system CentOS Linux 6.9
Perl version 5.010001
Path to Perl /usr/bin/perl
BIND version 9.8
Postfix version 2.6.6
Mail injection command /usr/lib/sendmail -t
Apache version 2.2.15
PHP versions 5.3.3
Webalizer version 2.21-02
Logrotate version 3.7.8
MySQL version 5.1.73
ProFTPD version 1.35
SpamAssassin version 3.3.1
ClamAV version 0.98.5

Found in cache …
Configuring webserver PHP settings …
… already done.
Applying web server configuration …
… done
Now installing Magento version …
Failed to extract source : Sub-directory magento was not found
… failed! See the error message above for the reason why.
Applying web server configuration …
… done