Lost root Access as Admin

I lost full admin access with root by doing the following. I was renaming a website (Change domain name) yesterday and everything worked well. I noticed that I forgot to change the description so I went back into Change domain name and changed description and saved. After I saved I no longer had access to all of my virtual servers - only the one. I logged out and logged back in as root and I still have only limited access to one site at a time -WTH happened? Is this a bug? How can I fix this?

So I was able to create a new privileged user thankfully which solved my problem - whew! Still don’t understand what happened but I don’t think it should have changed the root user just because I changed the domain name description!

It used to be possible, several years ago, to assign ownership of a domain to the root user, and that would lead to exactly this situation. That should no longer be possible (and it makes no sense to assign a domain’s ownership to a root or admin user), but somehow people still report this issue every now and then…we don’t know how folks are doing it. Virtualmin shouldn’t allow it.

Are you using current versions of Webmin and Virtualmin? (1.981 and 6.16)

As for how it could happen, browsers could autofill some of the fields on the Edit Virtual Server page…and if you didn’t notice, and saved it, this could happen (if Virtualmin didn’t prohibit it…but, apparently we still don’t handle every case).

Actually, though, the owner can’t be changed on Edit Virtual Server page, so browser auto-fill can’t be to blame. So, I don’t know how you got there!

I was able to create a new privileged user which tells me that root is still root but after the change domain save it removed all of the super user privileges- I think. Once I logged in as the new privileged user everything was back to normal. I can still log in as root but with minimized privilege view. I suppose its possible to give root those permissions back but I am not going to try that.
I installed this version back in the spring of this year so its not that old. So what do you recommend I do with the root user account?

How I got here- A client had a domain name pointing to a home directory that did not have the same name so I repointed the the home directory, that worked fine. Today I noticed that the description still had the old name - it was a minor thing but felt I should change it to reflect the actual domain name. I went back to Change domain name and changed the description. After the save my permissions changed. It’s possible I missed something regarding defaults but that’s what happened.

I discovered one more thing - I would call this a bug - but when I changed the /home directory via Change Domain Name, it did not change all of the php configuration items - I had to go into Services PHP-FPM Configuration and change the Directory Upload setting and more importantly the Session Options->Directory for Session Files (they were pointing to the old home directory which was breaking the php application - it was unable to save sessions). I would think that after renaming the home directory these options should change with it.