Logs Missing on Admin user screen

OS type and version REQUIRED
Webmin version REQUIRED
Virtualmin version REQUIRED
Related packages SUGGESTED

OS Centos
Webmin 2.105
Virtualmin 7.10.0 Pro

On the regular Admin screens, under all the domains, there on the left under the Logs and Reports used to be Access_log and Error_log choices. They appear to have disappeared… They do appear if you enter the admin screens for just one domain.

If its my mistake, please point me in the right direction. If its not, please make it all better :slight_smile:

So you talking about root user?
Also what Centos version?


Centos 7.9. yes, need to get it upgraded…

Looks like this. No logs available…

And yes, as root user. Doesn’t matter which domain I look at either. Worked before this last update.

Only thing I can think is to run re-check config.
You could also disable and enable Apache on each virtual server and see if corrects anything.

Thanks for your help.

But it didn’t matter, still broken.

And 2 servers now have the same issue. The other one is Virtualmin GPL, same hardware, save versions, exactly.

Changing themes makes no difference either.

If you do change theme settings - do remember to clear cache - easily missed.

Screenshot 2024-04-03 100839

Me too. All access and error logs have recently vanished on several servers I manage, running a mix of Ubuntu versions (and a mix of apache2, nginx and openlitespeed). By “vanished” I mean the options to view the logs no longer appear in Virtualmin > [select site] > Logs and Reports. By “recently” I mean the last few days.

The log files themselves are still in /var/log/virtualmin and can be viewed from Webmin > System > System Logs if you know where to look.

I’ve tried a “Re-Check Configuration”, “Limits and Validation”, clearing the theme cache, logging in as root. Nothing makes any difference so far. Happy to give admin access if that helps.

Yay, its not just me.

Mine is still broke. Doesn’t work in “virtualmin framed theme” either. Current up to date Virtualmin GPL and Pro.

Seeing you have pro, maybe log a ticket.

Just did. Sorta wanted to see if anyone else saw this before I yelled louder. So, yelling louder has happened.

Fixed it.

If you use a non-default “root” user, and its an upgraded installation, go into webmin then webmin users. Find the account you are using, then dig down and turn on “System Logs Viewer”. Joe was nice enough to do the hard work figuring it out, all props to him.


Thank you, but this not solving for me. It doens’t appear in any case loggin with a webmin user. I notice that with a real sudoers users There is Apache Access and Errors logs.


I agree you do need System Logs Viewer enabled now as noted above, that’s a change.

There’s a cache issue as well - using incognito mode and clearing my browser cache helps I think.

Yes. It solves cleaning the browser cache (and for me a server reboot). Thanks

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.