Livepatch + Virtualmin. Confused in Colorado

I’m a tad stuck knowing what to do. If I run the “livepatch status” I get the following -

sudo canonical-livepatch status
[sudo] password for nigel:
last check: 17 minutes ago
kernel: 5.4.0-47.51-generic
server check-in: succeeded
patch state: ✓ no livepatches needed for this kernel yet

But when I open up Virtualmin / Webmin I have a message that the system needs rebooting.

It’s also difficult to know for certain because the reported version of the kernel does not seem complete -
Kernel and CPU - Linux 5.4.0-47-generic on x86_64 (we are missing the .51)

If however I run the uname -a command I get the following -

Linux 5.4.0-47-generic #51-Ubuntu SMP Fri Sep 4 19:50:52 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

Which leads me to believe that I am running the latest kernel.

Can anyone help to let me understand if a reboot is or is not required.

Many Thanks - Nigel.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.