Limit of attachments in Roundcube

I have installed Virtualmin and Roundcube.

I can not attach files bigger than 1Mb.

I don’t find where I can increase the size of files attached.

If I send messages using Usermin, I can attach big files.

Can anyone help me?


System Information:
OS type and version : Ubuntu 24.04.4
Webmin version : 2.111
Virtualmin version : 7.10.0
Related packages : RoundCube 1.6.7

Maybe that’s a php limit, check the php resource limits.

I think that is the problem: the php resource limits.

I don’t have the PHP-FPM configuration in my panel (I don’t have Virtualmin Pro), I only can access to PHP options.

I have modified manually the file/home/tse-iberica/etc/php8.3/php.ini (the virtual server uses php 8.3):

; File Uploads ;

; Whether to allow HTTP file uploads.
file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not
; specified).
upload_tmp_dir = /home/tse-iberica/tmp

; Maximum allowed size for uploaded files.
upload_max_filesize = 1G

; Maximum number of files that can be uploaded via a single request
max_file_uploads = 20

Perhaps the problem is php.ini in /home/tse-iberica/etc/, because it was a symbolic link to /home/tse-iberica/etc/php7.0/php.ini

You don’t need a pro licence of Virtualmin to be able to access php-fpm configuration. I can access it on Virtualmin GPL.

There are very few differences between Virtualmin GPL and PRO. See

Then I don’t understand why I don’t have the PHP-FPM option in the menu.

This is the error I got when I try to attach a file bigger than 2 Mb:
Error: Request entity too large

Which php script execution mode is currently selected for that virtual server / domain? Check Virtualmin → Web Configuration → PHP Options

That is not a Pro feature. PHP-FPM is available in Virtualmin GPL.

Something is absolutely bonkers in your GUI, though. I have no idea what’s happening. The menu is crazy. Are there JavaScript errors in the web dev console? Are you running a weird/old browser?

I’m running PHP 8.3.6 in PHP-FPM mode.

I’m using Firefox 119 and I don’t have JavaScript errors in the web dev console.

I have solved it!

I have searched Request entity too large in Google.

I have found the information in this page:
request entity too large nginx

I have added the directive
client_max_body_size 16M
(inside http) in the file /etc/nginx/nginx.conf and I have restarted nginx:

http {

    client_max_body_size 16M;

1 Like

Well done! And thanks for letting us know.

Traditional wisdom would have us changing all the other usual settings but with Nginx, client_max_body_size needs to be specified too.

The OP did not mention that nginx was being used, so the assumption would be a default install (apache) but it’s agood one to remember

I forgot to mention I was using Nginx, because it is important.
I should have put it in the system information.


Perhaps the system information requested/copied should be amended to include the webserver as that information seems to be important when discussing so many topics on Virtualmin.

1 Like

@stegan thats not a bad ideam, would you add a githib issue to webmin or Virtualmin for this?

I’m still not sure what Webmin really has to do with serving web pages on a specific domain. Though the “type of server” is listed and managed under Servers in Webmin so is probably just as relevant under Webmin.

We are (in this side discussion - that sorry - I know should have been posted/moved to a new/different discussion group) really talking about the Dashboard

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.