Letsencrypt can't get SSL cert

SYSTEM INFORMATION
OS type and version Ubuntu 22.04.1
Webmin version 2.001

Hi All,
I’ve got everything just about perfect with this server, except for the SSL cert for the main host.

The missing bit here seems to be the webroot directory for Webmin.

I’ve tried various combinations of directories found on the internet but no dice

  • any help greatly appreciated!

@aconnor,

Setup the “main host” as a regular domain with only “Apache” and “Apache SSL” enabled. Then under “Server Configuration > SSL Certificate” click “Set As Default Service Certificate”. Everytime the certificate is renewed, it’ll renew for Webmin/Usermin (Virtualmin) automatically.

*** Professional, Affordable, Trusted Technical Assistance – https://tpnassist.com ***

Thanks @tnpsolutions,
I didn’t understand this bit-
‘Setup the “main host” as a regular domain with only “Apache” and “Apache SSL” enabled’

Does this mean
'Go to VirtualMin
select 'Create Virtual Server
Use the main hostname as the ‘Domain name’
unselect everything except ‘Setup Apache website’ and ‘Setup Apache SSL website’

etc?

@aconnor,

Yes, you understood correctly. Cheers!

Thanks so much for the reply.
In case anyone else has a similar issue, here’s what happened-

Following these instructions initially resulted in an error

Requesting a certificate for host.domain.com.au from Let’s Encrypt …
… connectivity check failed

So I went back into

Virtualmin/MyServer/Server Configuration/SSL Certificate/Let’s Encrypt

And tried again with ‘Test Connectivity’ turned ON

…and it worked!

It also will fail if server.domain.tld isn’t defined in authoritative DNS for domain.tld because it doesn’t yet exist anywhere, which is not an uncommon situation when setting up a new server.

Richard

In this case the DNS record was already set up and working, so maybe another issue. Not really concerned, just trying to be complete in case it helps others.

Thanks again for your help

A