Let's Encrypt wildcard certificate

OS type and version Debina 11
Webmin version 2.021
Virtualmin version 7.7
Related packages SUGGESTED


I’m trying to request a wildcard certificate with let’s encrypt, but i receive the following error:

Requesting a certificate for domain.it, *.domain.it from Let's Encrypt ..
.. request failed : Domain has no website, and DNS-based validation is not possible

I have added the wilcard entry in the Apache configuration (checking " Website matches all sub-domains?" option) and there is a website under the main domain.

What I’m doing wrong?

You cannot validate for a wildcard certificate without using DNS validation. And, you can’t use DNS validation if you aren’t managing DNS with Virtualmin.

You generally should not use wildcards. They have security implications on top of being more difficult to validate, if you’re not hosting your own DNS.

This is irrelevant. A website cannot be used to validate a wildcard cert with Let’s Encrypt.

Requesting a wildcard cert (I know there is a tempting checkbox there) but the general advice is don’t use it.
It is not needed. When you add a sub domain in Virtualmin it will make the appropriate request for that sub-domain and it will usually succeed.

Sorry @Joe you type quicker and give a better explanation :+1:t2:

Hi Joe, so basically if I want to host my email outside, but everything else on server - I have to manage domain outside of dns provided by virtualmin - is that correct - if it is, we all know settings for this but how one can make sure that @* is wild ? is that at registar end point or at yours(virtualmin managed ns…es?)

ok, thank you both for your reply.

I don’t know what you’re asking, but it sounds like a different problem. So, make a new topic and maybe phrase the question differently and I’ll try to understand what you’re trying to accomplish.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.