Leading / that wont go away

When setting the defaults for new domains I did it like pictured which unexpectedly produced /home/sites//domain.com. I’ve altering it via the change domain options (“that directory already exists”) as well as trying to fix it in the apache module and manually in httpd.conf however it still pops up in places like virtual server summary and is also causing issues with the file manager (either giving a directory doesn’t exist error or fails to open altogether). Did I missing something somewhere or do I just have to delete the server and remake it?

slash

SYSTEM INFORMATION
OS type and version almalinux 9.1
Webmin version 2.001
Virtualmin version 7.3

@Lobstrosity,

On the screen show, you simple add the variable $DOM

You added the preceding forward slash which caused your problem.

@staff perhaps a validation could be added to the config page to prevent this type of issue for others. Just a thought.

No I know now. I added it because the home directory base default was /home so i figured this field would be formatted the same way.

I’m just curious if there’s anyway to fix it now without having to recreate the server.

@Lobstrosity,

Disable Apache and Apache SSL, then re-enable. It doesn’t delete your home directory, just re-creates the configurations.