Lately... All Installs/Updates Failed

** Operating system: CentOS Linux 8.4.2105 **
** OS version: Linux 4.18.0-305.3.1.el8.x86_64 on x86_64 **

I’ve been using Webmin & Virtualmin for about 1 year on my Linux server. I’ve been installing updates with 1 click every time they are available without any problems, until now…

I am receiving the following error(s). What do you recommend I do to get these updates installed, and secondly, what can I do permanently so I don’t have to manually manipulate the installer each time in the future? Thanks so much for your time.

Last metadata expiration check: 0:48:15 ago on Tue Jun 29 15:09:43 2021.
Error:
Problem 1: cannot install both OpenEXR-libs-2.2.0-12.el8.x86_64 and OpenEXR-libs-2.2.0-11.el8.x86_64

  • package OpenEXR-devel-2.2.0-11.el8.x86_64 requires OpenEXR-libs(x86-64) = 2.2.0-11.el8, but none of the providers can be installed
  • cannot install the best update candidate for package OpenEXR-libs-2.2.0-11.el8.x86_64
  • problem with installed package OpenEXR-devel-2.2.0-11.el8.x86_64
    Problem 2: cannot install both ilmbase-2.2.0-13.el8.x86_64 and ilmbase-2.2.0-11.el8.x86_64
  • package ilmbase-devel-2.2.0-11.el8.x86_64 requires ilmbase(x86-64) = 2.2.0-11.el8, but none of the providers can be installed
  • cannot install the best update candidate for package ilmbase-2.2.0-11.el8.x86_64
  • problem with installed package ilmbase-devel-2.2.0-11.el8.x86_64
    Problem 3: cannot install both libgs-9.27-1.el8.x86_64 and libgs-9.25-7.el8.x86_64
  • package libgs-devel-9.25-7.el8.x86_64 requires libgs(x86-64) = 9.25-7.el8, but none of the providers can be installed
  • cannot install the best update candidate for package libgs-9.25-7.el8.x86_64
  • problem with installed package libgs-devel-9.25-7.el8.x86_64
    Problem 4: problem with installed package ImageMagick-devel-6.9.10.86-1.el8.x86_64
  • package ImageMagick-devel-6.9.10.86-1.el8.x86_64 requires ghostscript-devel, but none of the providers can be installed
  • package libgs-devel-9.25-7.el8.x86_64 requires libgs(x86-64) = 9.25-7.el8, but none of the providers can be installed
  • cannot install both libgs-9.27-1.el8.x86_64 and libgs-9.25-7.el8.x86_64
  • package ghostscript-9.27-1.el8.x86_64 requires libgs(x86-64) = 9.27-1.el8, but none of the providers can be installed
  • cannot install the best update candidate for package ghostscript-9.25-7.el8.x86_64
    (try to add ‘–allowerasing’ to command line to replace conflicting packages or ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)
    … install failed!

No packages were installed. Check the messages above for the cause of the error.

Try: dnf clean metadata

1 Like

Looks like newer packages are late to the repository. If so the problem should sort itself out in a day or two without doing anything aside from dnf update once packages are ready. I’ve seen errors like this lately but updates installed the following day. Between upstream and downstream it seems CentOS 8 isn’t as coordinated as it used to be.

1 Like

Thank you, Joe. I tried running that command and it looks like the metadata was updated. However, after running that command and attempting to install the updates again, I got the same errors. So I tried what Ramin suggested. (see below)

sudo-dnf-clean-metadata

Thank you, Ramin. I tried what you suggested - and it’s showing me 9 problems (up from 6).

Anything else you could suggest that I try?

You’ve enabled third party repos. Probably ought to ask them. Or don’t do that unless you really know what you’re doing and really need whatever packages you’re getting from those third party repos.

Does anything good happen if you run dnf clean all, dnf makecache and dnf distro-sync?

I agree with Joe about third party repositories. That’s the source of your problem and odds are that others are having the same problem you are having if the repo is to blame.

You’ve got MariaDB 10.4 that I assume comes from SCL, while 10.3 is the official default. With CentOS 8.4 MariaDB 10.5 is an official option now. There’s no 10.4 from AppStream, oddly enough. But all this really shouldn’t matter unless dnf is set to the wrong module. Output of dnf module list mariadb will tell you.

What’s puzzling is that third party repos that were working suddenly can’t find packages (since updating to CentOS 8.4?). So I’m still wondering if the SCL repo is just late, or is even fizzling like EPEL8 did with PHP packages a while back.

Those aren’t SCL packages. SCL packages do not conflict with standard system packages, and they aren’t named like that.

Right, I forgot about ‘rh-’ package names. And after a closer look I see both MariaDB 10.3 and 10.4 duking it out.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.