KVM guest system crushed

Trying to bring up KVM guest system. Working through VNC client, which gives the four options in the firsth screenshot. Tried every single of them - no joy.

It later suggests to run fsck manually as in the second screenshot, but how I do that if I can’t even get into the command line of the guest?

By the way, I’ve made sure to attache two screenshots, however it doesn’t show them here.

Edit: Node attachments don’t show, but comments’ do.


An inconsistent filesystem can sometimes occur with Linux… and when that happens, you’d need to startup the distro in single user mode to work on it (ie, to run fsck on your partitions).

You can read about how to do that in the CentOS guide:


It looks like your attachments did show up in your second comment, BTW.


Eric, thanks for prompt reply. I really need to fix this ASAP.

I would definitely follow your advice if it was a dedicated server. Now this is Cloudmin KVM guest. How do I get into it? Working through VNC doesn’t help - it just keeps restarting itself.


When you say “it keeps restarting itself”, what do you mean by that exactly?

Do you mean that the guest is rebooting? Or that VNC is quitting out?

If you can describe exactly what you’re seeing, when it’s occurring, and if you’re seeing any error messages when that happens, that would be helpful.

Also, I haven’t tried this before, but there’s apparently an app called guestfish which allows one to run fsck on a KVM guest from the host.

There’s information about doing that on the first comment to this post:


I wrote to Jamie about this situation and after looking into my VNC he advised to check the disk, what I am currently doing. Will report a while later on results…

Please remember that emailing Jamie isn’t the way to get support :slight_smile:

For folks using Virtualmin and Cloudmin GPL, the forums are the way to obtain support.

Or, if you’re seeing a bug, you can file an issue in the Support Tracker.

If you’d like Premium support, you’re welcome to purchase Virtualmin or Cloudmin Pro, and you can then use the Support Tracker as often as you would like.

But even for Virtualmin/Cloudmin Pro customers, we ask those folks not to email Jamie directly, unless he directs them to regarding a specific issue (which is what occurred yesterday when Jamie offered that you could email him about a particular issue, that was so that you didn’t need to post sensitive information in the forums).

Jamie is on vacation now, and he’s too nice of a guy to say no… but if everyone did that he’d never get a vacation :slight_smile:



Thanks Eric,

I didn’t know Jamie was on vacation. Well, anyway he advised to mount the system and try to save my files, but they all were gone. Telling this if anyone hitting this page in the future will ask if I was able to rule out the situation.