Keep getting wrong group for a renamed domain

OS type and version Debian 10
Webmin version 1.991
Virtualmin version 7.0-4
Related packages FPM

Hey, I have a domain that got renamed, and when something is changing, I keep getting wrong groups (the old one and not the new group, which is displayed properly in the summary) for example in the php FPM config, so the process is not starting anymore. Where does Virtualmin getting those from, figure it has somewhere a “skeleton” file or something so can you guys suggest a path/file to edit that? Thanks!

Do you use UI or CLI to rename a domain? Do you set to assign a new administrator name manually or automatically or leave unchanged?

I have given it a try and it work for me. Can you provide more details and steps on how to reproduce an issue?

User and group for virtual server PHP-FPM config must not change and should always stay as root:root.

Thanks for taking the time @Ilia !

It was a while ago, and pretty sure I did it in the UI, but didn’t notice until someone tried recently to change the PHP version for that specific domain. Sure it was a glitch somehow, and maybe not reproducible right now. Problem is in my case (all the servers I manage), I have specific users and groups in the pool confs? The files at /etc/php/X.Y/fpm/pool.d/ (all Debian now BTW)?

They look like:

user = mumu
group = mumunewgroup
listen = localhost:8000
pm = dynamic
pm.max_children = 9999
pm.start_servers = 1
pm.min_spare_servers = 1
pm.max_spare_servers = 5
php_admin_value[upload_tmp_dir] = /home/mumu/tmp
php_admin_value[session.save_path] = /home/mumu/tmp
php_admin_value[memory_limit] = 128M
php_admin_value[post_max_size] = 24M
php_admin_value[upload_max_filesize] = 16M
php_admin_value[max_execution_time] = 121
php_admin_value[max_input_time] = 60

Everything works fine everywhere, but for a single domain, that got renamed (as I surely remember it, and I see the old group, of the old domain, not the new one) I get when changing PHP versions: group = mumuoldgroup

And so the fpm process is not starting anymore, with a very specific error stating exactly that, don’t have it right now.

So my assumption is that Virtualmin is pulling that from somewhere (where exactly is my question?) - everything else seems fine, rights on files and such.

Thanks again!

I get it now. Yeah, if either user or group is not set correctly FPM server won’t start.

It would be interesting to find out what the source of the problem is.

If you go to web-server configuration for this domain, does it have a record localhost:8000 or it’s set to something else?

Was just an example with 8000. In Apache config I have

<FilesMatch \.php$>
    SetHandler proxy:fcgi://localhost:8015

The FPM service is not complaining about the port but the group, as it keeps getting the old one - I edit it, it works restarting FPM, I change the PHP version, and is back to the old one = no more PHP. In FPM pool config I have:

listen =

If you check in domain config file on Virtual Server Summary page, by clicking on Domain ID, i.e.:

… does it have correct uid and gid set?

Thank you for putting me on the right tracks, it was the ugroup= that was wrong, valuable info!

This is solved!

Do you have a clue how this could happen? Is this an old domain?

No clue but this a old domain, 2015 :dragon: so that’s why I was telling you not to try and replicate the problem :slight_smile:

Funny thing validation was telling me everything is fine… that could worth investigating.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.