Kavita Email switch to sites email

OS type and version Ubuntu Linux 20.04.5
Webmin version 2.001
Usermin version 1.860
Virtualmin version 7.2-1 Pro
Theme version 20.02
Package updates All installed packages are up to date

I’m using Kavita to host a book site, but using their default email system, no one is getting the emails (not even in spam), so I’m wanting to use my own sites email server, but I’m unsure how to go about it.
In Kavita, you need to specify the email server address, and no matter what I enter, it says the test fails.
Is there a specific address to use for instances like this? It want’s an https address, and I’ve tried using my https webmail address, but that fails as well.

Any one have any ideas?


Have you checked your mail log? If the message in question has a status of “sent” then it means it left your server, and was received by recipient server.

What it DOES NOT mean is that the message was actually delivered to the recipient “inbox”. It could have been filtered at the server level, or by a spam filter at the mailbox level.

*** Professional, Affordable, Trusted Technical Assistance – tpnAssist.com ***

By default, it’s not using my email (hence the question), but uses Kavita’s own email client. But it’s apparently not working, so I’m trying to use the one for my domain.


Are you saying your server isn’t sending the message?

From the email page in Kavita:

Kavita comes out of the box with an email service to power flows like invite user, forgot password, etc. Emails sent via our service are deleted immediately. You can use your own email service, by setting up Kavita Email service. Set the url of the email service and use the Test button to ensure it works. At any time you can reset to the default. There is no way to disable emails for authentication, although you are not required to use a valid email address for users. Confirmation links will always be saved to logs and presented in the UI. Registration/Confirmation emails will not be sent if you are not accessing Kavita via a publicly reachable url. If you want Send To device to work, you must host your own email service.

Which does not send any messages. So I’m wanting to use my own domains email address to send the invites from.
It has to be in the form of https://[emailserver] and I’m not sure what my domains email server address is. I’ve tried webmail.domain, mail.domain and email.domain and none work.


Sounds like you should be directing your questions to the developer of the software. I’m sure they’d be in a better position to address the matter.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.