Just moved to new server, can't authenticate to SMTP server

I just moved to a new server and migrated all my sites using Virtualmin(it runs on both the old and new servers).

I’m trying to send an email but I can’t authenticate using one of the added mail users. Thunderbird keeps asking me for a correct password. I can send mail using the administrator account though.

Using the admin account I don’t use the xx@domain.com format but just the username. On my old server for added email accounts I always used the xx@domain.com format for the username.


Here is the error log:

Sep 14 08:07:23 www2 postfix/smtpd[11823]: connect from c-xx-xxx-xx-x.hsd1.tx.comcast.net[xx.xxx.xx.x]
Sep 14 08:07:25 www2 postfix/smtpd[11823]: warning: SASL authentication failure: Password verification failed
Sep 14 08:07:25 www2 postfix/smtpd[11823]: warning: c-xx-xxx-xx-x.hsd1.tx.comcast.net[xx.xxx.xx.x]: SASL PLAIN authentication failed: authentication failure
Sep 14 08:07:27 www2 postfix/smtpd[11823]: warning: c-xx-xxx-xx-x.hsd1.tx.comcast.net[xx.xxx.xx.x]: SASL LOGIN authentication failed: authentication failure

Note it works fine when I log in at the administrator account for that domain…


You may want to verify that saslauthd is running with the -r flag… you can verify that by running the command:

ps auxw | grep saslauthd

We can help fix that if it’s not, just let us know what distro you’re using :slight_smile:


I’m running Centos 5.2 x64

Looks like it is running:

root 16648 0.0 0.0 48832 1192 ? Ss 08:12 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam

root 16650 0.0 0.0 48832 1176 ? S 08:12 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam

root 16651 0.0 0.0 48988 1300 ? S 08:12 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam

root 16652 0.0 0.0 48832 1092 ? S 08:12 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam

root 16653 0.0 0.0 46740 300 ? S 08:12 0:00 /usr/sbin/saslauthd -m /var/run/saslauthd -a pam

root 22892 0.0 0.0 61148 740 pts/1 S+ 15:42 0:00 grep saslauthd

Thanks for the help.

It doesn’t look like you have the -r flag enabled… you can add that by editing “/etc/sysconfig/saslauthd”, and changing the OPTIONS= line at the end to read:


After setting that, you can restart saslauthd with:

/etc/init.d/saslauthd restart

Still not working.
Here is the maillog after the changes…looks the same:


Thanks. I edited the file to look like this:


restarted saslauthd and still the same issue. The admin account can authenticate to use the smtp server but normal mail accounts cannot.


Ok I solved the problem…

You made a typo above. It should have been “FLAGS=-r” and not “OPTIONS=-r”… I thought it was odd that no OPTIONS= was present in the default file… Oh well I figured it out.

Thanks for the help.

Oh any advice on how to get Postfix to report “www” instead of “www2” in the logs? All hostname and DNS entries check out in Webmin and Postfix main.cf…