Jailkit config bug

Operating system: CentOS
OS version: 8.2

I tried to use chroot jail into a freah server install.
It give me error while creating a new virtual server referring to row 118 in
/etc/jailkit/jk_init.ini
A quick look shows a duplicate entry in the openvpn section. I solved commenting the first occourence:

[openvpn]
comment = jail for the openvpn daemon
paths = /usr/sbin/openvpn
users = root,nobody
groups = root,nogroup
###includesections = netbasics
devices = /dev/urandom, /dev/random, /dev/net/tun
includesections = netbasics, uidbasics
need_logsocket = 1

The file is dated “Jan 4 2020”…
Am I the only interested in chroot jail?

Regards, P.

Hi,

Thanks for the heads up.

We just discussed it with @Joe yesterday. It should be fixed in the near future.

Same “error” in an “old” CentOS 7.x installation where the file (/etc/jailkit/jk_init.ini), is different in size and dated 31 may 2017.
But no problem to create chroot users there.
N.B.: users created in CentOS 8.x can’t access via SSH until I change the password using the standard passwd command that create a password with longer hash than virtualmin …
Anyway, for chrooted users, they log in succesfully (after have been added to the AllowUsers directive in sshd_config in my tests), but are logged out immediatly like if the /sbin/jk_chroosh shell is non appreciated from the system.
Any config tips that I miss?

Thanks, P.