Issues upgrading Ubuntu 12.04 Precise to 14.04 Trusty

I ran into a few issues with my Virtualmin Pro installation when upgrading that I wanted to share.

I followed the instructions here

and kept my versions of all config files as recommended.

Most critical was the fact that email wasn’t working after the upgrade. It was not possible to fetch mail and Roundcube webmail login was not working - it complained about

Connection to IMAP server failed.

Looking at /var/log/mail.err it was full of this type of error:

ns1 dovecot: imap(): Error: user : Initialization failed: namespace configuration error: inbox=yes namespace missing
ns1 dovecot: imap(): Error: Invalid user settings. Refer to server log for more information.

This was solved by adding

namespace inbox {
inbox = yes



as explained here:

Another showstopper was Apache not being able to start but complaing about SSLMutex:

AH00526: Syntax error on line 49 of /etc/apache2/mods-enabled/ssl.conf:
Invalid command ‘SSLMutex’, perhaps misspelled or defined by a module not included in the server configuration

This was easily fixed by commenting out the offending line in ssl.conf as recommended here:

Now a few hours after the upgrade all seems to be working well.

Thanks for sharing your findings! We’ll do some testing and update the docs.