Issues restoring backup on another server

I have a machine with webmin 1.480/virtualmin 3.703, which I have done a backup of. No issues that I know of here!

I have a second machine with webmin 1.510/virtualmin 3.78.gpl, which I am trying to restore these backups to, as is this our fallback machine.

When i run through the restore script, I get this error:

“Restore failed : Missing file to open at WebminCore::/usr/share/webmin/ line 2704”

I checked that line in the script and it had something to do with loading a tempfile, not too much else to go on.

But, each time I run the script, it gives me this error one virtual server ahead, so theoretically if I was to run this another 30 times or so I’d import everything :stuck_out_tongue:

And of course, I am using two different versions of virtualmin here! I was hoping that the newer version will not have problems imported slightly older files, but if I am wrong on this let me know. I still have time to downgrade before everything gets imported!

Thanks, hopefully I can get this all figured out