Issues initializing Squid custom cache directories

this is Riccardo from Italy. I am relatively new to Linux OS world and Webmin as well.
I setup a virtual machine for running a Squid proxy server on Centos 7 (build 1908). I then installed Webmin (latest version 1.94) and I try to manage Squid proxy through the according module.

I don’t understand if the following is a bug or anything else due to my poor knowledge.
I wanted to initialize the squid cache on a different directory than the default one (/var/spool/squid). So I selected Squid Proxy Server module, then Cache Options, flag radio button “listed…” and filled in the underneath section with my desired custom directory for caching. The latter was previously created and set permissions to 0750 and owner/group squid:squid.

When I tried to initialize the cache directory it was initialized the default directory and not my own. Furthermore, I wanted to create a cache_dir of 10240 MB, but initialization was set to 100 MB.

Is it weird or not? What I was wrong?

Thank you.