[ISSUE] Front-end Text Only

Hey all,

I have been using Webmin/Virtualmin on my VPS for the last couple of years. I haven’t been checking it regularly. Last month I logged in to see to check what updates are available and realized I have no images - only text - in the menu and I can’t access some features. I tried changing the template but that didn’t work out either. I tried logging in from my mobile phone and the regular mobile front-end was working fine. Trying other browsers, other terminals didn’t help either - the front-end doesn’t show images once I log into the Virtualmin.

Here’s the link to the screenshot of the issue, this is the screen I get once I’m in.

Does anyone have any insight as to why I might be having this problem?

All input very much appreciated, thanks in advance.

Theme possibly changed / forced to mobile theme?

I have swapped the front end to several others but all of them had the same issue - text only. Can’t identify the problem unfortunately.

What isnt working virtualmin or your website…looks to me like your website isnt working.

Having said that, i am suspicious …it appears your revenue adds are working. Is this really a virtualmin problem or an attempt to draw in money? It either that or someone has hacked your website perhaps?

Not sure if I got it right…all websites hosted on the server are working perfectly well. Its only Webmin website that does not work, which has its own web server. “Attempt to draw in money” ? Nobody’s checking the Webmin other than me.

Appreciate any input on this one, thanks everyone!

Normally one wouls say your css is at fault but as i dont know website structure,. What happens if you create a new virtual server for your front end?

Try opening the frontends in a new “private” browsing session to be sure its not a browser cache issue.

I’ve tried several browsers/devices/connections, same result.

Got news. When I log into Usermin (port 20000), website works perfectly well.
I tried changing the port of Webmin to another, still getting the same problem.

I started to think that the webmin web server has no issues but the templates might have a problem.
Does anyone have any clue how I can update all HTTP files without uninstalling/reinstalling Webmin?

All works fine - its just Webmin not working. But then again, websites are hosted by server’s Apache whereas Webmin has its own web server.