Issue after Change of Ports

Hello everyone!

I am trying to run a single virtual sub-server on ports XXXX and YYYY instead of 80 and 443, so I go to ViMin > Server Config > Change IP Address and I establish the ports I want to use.

Doing this renders all other virtual servers inaccessible, even though those are running over the classical ports (confirmed under Webmin > Servers > Apache Webserver). Why is that? :thinking:

Thanks in advance :peace_symbol:

Hi,

What Virtualmin and Webmin versions do you have installed?

Edit: I have given it a try with latest Virtualmin 6.10 and all seems to be working just fine.

Webmin 1.953, ViMin 6.10 … I don’t understand the error because it is a pretty straight forward setting, and then again I am quite the noob when it comes to networking … are there any logs you would like to see?

Check Apache conf file containing VirtualHost configuration. I wonder, are they bind using * or concrete IP address?

Hi @Ilia

When everything is working, all domains have Virtualhost containers contain the same IP and ports.

<VirtualHost myip:80<</VirtualHost< <VirtualHost myip:443<</VirtualHost<

Now, I change the ports of my sub-domain and everything breaks even though only the right VirtualHost containers on httpd.conf have been changed. I also tried changing the prots for the domain and sub-domain, but I cannot access any websites. Neither the websites still on ports 80/443 nor the websites on ports xx/yyy.

I try reading error_log files, but nothing is registered on them. :man_shrugging:

If I change the parameters back to normal, nothing works anymore. So, it must be something else that is changed when changing the ports through > ViMin > Server Configuration > Change IP Address :thinking:

Check status output for systemctl command?

systemctl status httpd # (or apache2)

You would need to check for global Apache Error log, not per server log. (Webmin/System Logs).

Compare how does config look like when everything is not working? :slight_smile: Additionally, make sure that Apache also listens on those new ports.

So, I don’t know how it didn’t occur to me, but you are right. The service isn’t running. I have had a look at:

systemctl -l status httpd

and

journalctl -xe

And the global Apache Error log



(the edit should say internal_ip:new_port_http)

I also had a look at the config files.

httpd.conf only had

Listen 80

and ssl.conf had

Listen 443
Listen internal_ip:new_port_http
Listen internal_ip:new_port_https

I tried deleting the lines with the internal ip in ssl.conf and just adding

Listen new_port_http

to httpd.conf and

Listen new_port_https

to ssl.conf, and this solved the problem. I just had to restart my computer. I don’t know why the computer wouldn’t just reload the modified config files without a restart.

PS: Please let me know if there is sensible information that I haven’t edited out of my screenshots. #help-home-for-newbies :laughing:

Thanks for your help @Ilia! You pointed me in the right direction :heart:

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.