Is this normal? Very slow to download new webmin version

OS type and version REQUIRED
Virtualmin version REQUIRED

I’ve tried in different Pi 4B’s, LXC, different version of Webmin 1.97, 2.00, 2.001, it takes a long time to download any update.

What could be wrong?

where did you setup the repository for webmin ? that is totally different to the repository I see and not a sourceforge one so on ubuntu it is set so

maybe change to this repository will help

I haven’t done any set up. Just using stock config.

I’ll check your advice… Going thru this route breaks my Webmin in 2 instances now.

It is downloading… I don’t know how to kill it now…


This is a Pi4B, Ubuntu 22.04.1 LTS. Webmin 2.000.

not sure a Pi can read that … my mistake didn’t notice the Pi
but this may be correct

Oh, not Raspbian OS… it is Ubuntu 22

Just followed the guide you gave me. Added the key, the repo.

Same error.

what are you seeing in the terminal when you run apt update ?
you did the fix broken bit as well ?


apt update has no error. Just a warning:
Ign:1 Index of /download/repository sarge InRelease
Hit:2 Index of /download/repository sarge Release
W: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

and when you run apt upgrade what are the errors

apt upgrade is fine. It completes the upgrade to 2.013.

I guess I’ll avoid the built-in Upgrade Webmin function.

Thanks you!

It should have worked fine and i guess it will the next time you try it

1 Like

:joy: yeah, next time it will work.


FYI, you should post this type of question in the “Webmin” category next time.

Ok, got it.

Will do next time.

Not sure how this site is set up but another Discourse site I use lets you edit the category when you edit the post.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.