IPV6 - Enable on Host? Fix og:meta not appearing correctly on social share 418 Error

OS type and version Ubuntu Linux 22.04.3
Webmin version 2.105
Virtualmin version 7.9.0
Related packages SUGGESTED

Recently i moved from a provider with shared hosting to a VPS , since then , the social network share of my site , and all the pages that are shared (including products) it does not show the image associated or any information that i configured in the wordpress plugin for that.
the support team of the plugin said that everything is ok , and could be a problem in the server configurations.

I researched a bit , and think that is because facebook uses ipv6 for this also , and i see that my vhost is not enabled for ipv6 as screenshot . could be because of that?

When i go to facebook debugger Sharing Debugger - Meta for Developers
, it retrieves me an error:

how can i enable ipv6 for my virtual host? because my VPS have one IPv6 address assigned also.

If this is not the problem can you kindly help if you know the issue?

Do you actually have a IPv6 (a DNS AAAA record)?
if your VM provider is managing DNS and has not provided, this get one

The AAAA record that i have configured in my DNS provider it’s the IPv6 address that it’s assigned to my VPS .
In my vps hosting i have the IPV4 and IPV6 IP’s that they assigned to me.
My VirtualMin VM is not providing any DNS.

Most of the problems that i searched was about IPv6 , but it could be other thing. I am so really tired on this :frowning:

That all sounds good - I am also finding it difficult to think it is anything other than a WP related problem.

I assume you have checked with a tool like Mxtools that the record is externally visible?

As WP is banned from my VS clients - I’ll have to defer to someone who uses it.
just guessing a setting in WP?

Check your IP6 address hasn’t changed, go to Change Ip Address on the virtual server and see if there is a new IP, my VPS does it too me sometimes. Very annoying. If it has update and also update the dns.

Issue fixed. Problem with the certificate CA auth. just added that bundle to certificate

Has Validate Virtual Server issue gone?

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.