IPv6 address failed! : No active interface found for eno33557248

Hi everyone, I’m having a hard time setting up IPv6, it’s a bit of a complicated setup.

I’m running a VMWare ESXi server that doesn’t actually have IPv6 on it. I couldn’t find a way to set up a tunnel through the hypervisor, so I set up a virtual machine with PFSense on it to run the tunnel and give out IPv6 addresses. The trouble is, I don’t want it giving out IPv6 addresses to anything but the VMs, so I created second virtual switch that is isolated to just the VMs with a second network interface on each VM. I figured this was the easiest way. So, I set up my second virtual server with CentOS 7 and put Virtualmin on it. This is my first time using CentOS 7 and it is a bit different for the network config. The adapters have weird names like eno33557248 instead of eth0.

So, I have one adapter set up with strictly IPv4, which connects to the tunnel through the main virtual switch that has the IPv4 connection to the internet. And a second adapter set up to give out the IPv6 addresses to the other VMs and route the traffic. I know I have the IPv6 working, because I can ping both ways from a remote location.

When running the check configuration I got this message.

Virtualmin could not work out the default IPv6 address for virtual servers on your system. You will need to update either the Network interface for virtual addresses or Default virtual server IP address fields on the module configuration page.

So I went and set Network interface for IPv6 addresses to eno33557248, which is the interface that just has IPv6.
Default virtual server IPv6 address is set to From network interface
Netmask size for IPv6 addresses is set to Default (64)

Still get the same message.

I tried setting Default virtual server IPv6 address to the static address I have assigned, and that seems to get past that error, but then I get this when adding a virtual server with a new IP address.

IPv6 address failed! : No active interface found for eno33557248

The interface is definitely active, or I wouldn’t have any IPv6 connection to ping.

Any ideas?

strange setup…
you dont have to have an interface with ipv6 setup in esx to be able to get ipv6 into a vm… it should just automatically work…

what does ifconfig eno33557248 show?

I am using Centos 7 and I don’t get an enoxxxxxx network interface, my OS reads eth0 unless I over ride it on /etc/sysconfig/network-scripts/

As I said, the server does not actually have IPv6. The provider does not support it yet, but they are working on it. Because I know of no way to set up a tunnel directly on the hypervisor and have esx give out the IPv6 addresses, I had to set up a virtual machine to make the tunnel and route the traffic. But because the server is directly connected to the internet, I don’t want my server giving out IPv6 addresses to anyone else who may be connected on the same switch as me in the datacenter. That’s why I isolated it to a VM only switch.

ifconfig shows
eno33557248: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet6 fe80::20c:29ff:feee:ca37 prefixlen 64 scopeid 0x20
inet6 2001:470:1f07:ab::1000 prefixlen 64 scopeid 0x0
ether 00:0c:29:ee:ca:37 txqueuelen 1000 (Ethernet)
RX packets 9677 bytes 7225042 (6.8 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3787 bytes 376419 (367.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

That’s interesting, I’m not sure why mine did that. It’s my first time installing it and that’s what it defaulted to. I’ve seen other people’s posts with devices starting with eno, so I just figured it was some new naming scheme in CentOS 7. Are you running the AMD64 version? Not that that should make a difference.

Interesting enough, when I do ifconfig, it does not show any new IPv6 address that I tried putting in when creating the host.

However, if I go to Webmin --> Networking --> Network Configuration --> Network interfaces, it shows my defauly address that I set as well as the one that I tried to give the new server in Virtualmin.

I use 64bit and it defaulted to eno as well… I found some instructions somewhere on how to change it back to nice eth names

Good to know. I may look into that at some point. It’s kind of a pain typing all those numbers sometimes. Do you remember where you found the info? If not I’ll just try google at some point.

I followed step 3 on here :slight_smile:

Thank you! Now I have easier interface names! Now, if only I could figure out the IPv6 addressing problems.