IPV4 Firewall Rules Appear As Empty List After Upgrade To Version 1.953

Hi guys, The IPv4 firewalls (I’m not using IPv6) were manageable until I upgraded to Webmin version 1.953 today. Please let me know what I need to look at and what to try so I can manage my firewall in Webmin again!

I check my firewalls list frequently so I am aware if Fail2Ban has been reacting to increases in attacks, and to add manual entries to block email spam sources. The upgrade fixed broken Lets Encrypt feature which I was about to come here to inquire about. The firewall rules consisted of a block of default rules generated by Virtualmin, followed by a block of my manual rules, and then several blocks of Fail2Ban rules. Every time I reboot the OS, I disable Fail2Ban and Save Configuration, and I did this several days ago. This image is all that I have now:


I tried changing the theme from Virtualmin Framed Theme to Authentic, since I have been aware that certain pages have differences in information, but it did not resolve the problem. I checked the Linux Firewall module settings and found nothing probably wrong:

I manually opened the /etc/iptables.up.rules file and found it actually contains my firewall rules as they were when I last saved them!

In the IPv4 Firewall config screen I tried to [Add a new chain named: test], but it tells me I’m not allowed to access:

I am logged into Virtualmin as root, and permissions for that iptables file are:

Thanks in advance for your help!

Please include your OS/version.

Linux 3.13.0-181-generic #232-Ubuntu SMP x86_64 x86_64 x86_64 GNU/Linux
It is running as a virtual machine under Oracle Virtualbox. Appropriate, no? :wink:

That’s an old as heck kernel. Is this Ubuntu trusty? That reached EOL about a year and a half ago.

I think there was a change to support newer versions of iptables, and maybe it broke older versions…I dunno. I have vague notions @Ilia made the patch in question, but maybe I’m misremembering (and maybe there wasn’t a change).

Edit: To be clear we don’t support operating systems that are not supported upstream. We just can’t. But, we also try not to break things like this, unless it requires giving up, e.g. new Perl features or something to maintain compatibility with EOL stuff. Nonetheless, you should be upgrading to a supported distribution.

It’s kernel was updated on July 9th and I install other updates regularly.
Actually, here’s the version info from the welcome message:
Welcome to Ubuntu 14.04.6 LTS (GNU/Linux 3.13.0-181-generic x86_64) (Trusty Tahr)

I would update to the latest Ubuntu but my partitions are too full and I’ve failed several attempts to expand them. :confused:

I’ve been tailing the Fail2Ban log as a work-around for that. It seems to be working fine without reporting issues. It seems that it can still see and modify the Linux Firewall just fine. All that is broken is Webmin’s ability to display and manage the list of rules.

I got a second wave of Virtualmin/Webmin updates today but my Linux Firewall control panel is still broken. I even rebooted the machine. Can anyone offer tips on how to fix this? Work arounds? Thanks!

It’s fixed here, sorry!

1 Like

Wonderful! I am able to see my firewall rules and add/remove a chain! Thanks for your swift response, guys!

Updated Ubuntu 18.04 server today inc Webmin 1.953 - same issue as AustinTX.
Have followed links thru to git-hub as recommended for patch, however when I go to /etc/webmin/firewall/ there is no file/firewall-lib.pl just:
-rw------- 1 root bin 204 Jul 16 06:26 config
-rw-r–r-- 1 root root 6915 Jul 16 10:39 iptables.save
and an older saved version from previous installation before update
-rw-r–r-- 1 root root 7417 Jun 19 13:53 iptables-20200619.save

Am I looking in the wrong place ? or is something not activated in Webmin?

@stumac Use LOCATE to find your file. Mine was located at /usr/share/webmin/firewall/firewall-lib.pl

Thanks AustinTX located path to file which is same as you listed!

1 Like

This topic was automatically closed 4 days after the last reply. New replies are no longer allowed.