Interspire Email Marketer problem setting login to bounce


Running Webmin version**|1.941|
Usermin version 1.791
Virtualmin version**6.08
Operating system Ubuntu Linux 18.04.3

I’m trying to install Interspire Email marketer onto my webserver using Virtualmin.
(I’ve installed it successfully on cpanel half a dozen times without a problem)

It will now send emails through default mail settings, log clicked links and process unsubscribes.- in other words it mostly works!

I cannot get the installation to process bounce processing. - I’ve tried to get it to access a email bounce account on the same machine, and on another external email server I control.
I cannot get it to send using an external specific smtp server either. - only the default.
All the right ports seem to be open. I’ve tried changing the port to all the possibles too, ie 25, 995 etc etc
I’ve tried reinstalling the Interspire programme.

The Interspire error logs say
Line 1499; time 1581855427; sending through smtp server
Line 1939; time 1581855427; smtp details: server: localhost; username:; password: ********* ; port: 995
Line 1954; time 1581855487; Got response
Line 1578; time 1581855487; Connection is boolean
Line 1582; time 1581855487; No connection

The Virtualmin system receives and sends emails sent in the conventional way through Webmin okay. I can also log into the email accounts on the Virtualmin server using Outlook etc.

My problem is that I cannot get bounce processing working, and I cannot access a smtp server other than the localhost one.

Can anyone help please?

Many thanks,