Insufficient space for subdomain - but server has space

OS type and version RHEL 8
Webmin version 7.2

When I use Installatron to install WordPress I get the following error:
“… Sufficient disk space is currently not available.”

Where/How can I resolve this issue?

There is a difference between server space and virtual server space. We need to get the terminology settled first.

Installatron is not our software. I can’t answer questions about software I’ve never seen.

Why not use the tried and tested Wordpress installer script included with Virtualmin?

looks like it could not write the files rather than disk space

this is the best option

Could this be caused by the quota size of the parent domain?

1 Like

I’m not sure how a remote piece of software would get that info, but it’s a valid point, my thought was that if the remote app could not upload it presumes there is a lack of disk space, that said there maybe the software is installed on the host system

Nope. It’s caused by using another hosting services software that isn’t compatible with Virtualmin because it doesn’t have permissions to write to Virtualmin and can’t see anything you’re trying to do.

You don’t use a CPanel software to work in Virtualmin. You use Virtualmin’s installer or you do it manually via Wordpress app upload.

1 Like

I suspect that might be part of the reason. It might not be the only reason, however. There could be permissions problems resulting from using a non-native installer.


This doesn’t really make sense.

Virtualmin is not the filesystem. You don’t “write to Virtualmin” when installing applications. You write to the filesystem.

I don’t know anything about Installatron, but writing to the filesystem in a Virtualmin system is no different than writing to the filesystem in a non-Virtualmin system. We aren’t taking over everything. We’re just a GUI on top of everything. Almost nothing needs to be aware of Virtualmin, and you can almost always follow the usual installation documentation for applications and such.

I do think that one should use our Install Scripts to install web apps, because I know they work and I know they make pretty good choices from a security perspective. But, also, a Virtualmin system does not demand everything be done in some special way; we try to do everything in the way an experienced RHEL or Ubuntu or Debian administrator would expect it to be done.

I have tried to install using this software … it tries to transfer the files through ssh but for some reason it fails on permissions errors …
from thier website

I guess this was the method tried rather than the cpanel/plesk/direct admin plugin method but who I knows as I appear to know nothing about anything

True. But getting long winded about it isn’t going to help him. Virtualmin set the permissions on the site when he used Virtualmin to create it.

Imagine going in to Virtualmin, clicking on the Virtualmin Wordpress Installer Script and then trying to go through your CPanel on Hostgator to install it onto a file system you set up in CPanel on Hostgator.

That is what he’s trying to do.

how … I pointed out there are numerous methods of installation from installatron on being through a plesk/cpanel/direct admin plugin other methods include upload via sh/ftp/sftp . installatron is not just for other flavours of control panel

Won’t permissions will be the same as those of the access credentials. If the user enters their access credentials, then those are what is used.

Why use a nail gun when you can use a hammer?

Just installed docuwiki via installatron, after reading the api documentation. The fix is to add the full path to the installation
the installatron default is public_html/directory
where it should be /home/user/public_html/directory
I guess the cpanel etc plugin just adds the /home/user bit to the path in the request to the api
hence the permissions issue, as it was trying to write to /public_html/directory.
in the op’s case it wouuld something like /home/user/domains/domain/public_html/directory assuming vmin has been used to create a sub server
Edit :
after your first app the next installs you just need to add the directory but be aware if you are adding to a sub server created in vmin you add this in a new domain in the installatron control panel

You’re missing the point.

Most hosting installers will not allow you to install on an outside server. They’re not engineered to do that.

He’s on Cpanel somewhere like GoDaddy or Hostgator or something and he’s trying to use the Installatron from his control panel to install on an outside server running Virtualmin.

I also have some hosting done on Greengeeks. They use Cpanel but not Installatron. They use Softaculous as their installer service.

If I try to launch that to install Wordpress, it will only allow me to use a domain I have set up with them. It won’t even allow you to type a custom address in it.

Installatron won’t allow it either. He just put the address in there and it didn’t work because it’s going to an outside Virtualmin server, not their own.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.