Installing Virtualmin module on Ubuntu 15.10 wily

I had difficulty running ./ It says “Failed to detect operating system”. I’m using Ubuntu 15.10 with webmin installed on DigitalOcean VPS.

$ cat /etc/issue Ubuntu 15.10 \n \l

I’ve tried to find in different forums but still couldn’t find a solution for the same problem.

I’ve read that Virtualmin supports up to Ubuntu 14.04 at the moment, does that mean I can’t get it installed in 15.10?


Unfortunately, Virtualmin only supports the Ubuntu LTS versions, so 14.04 is the most recent you could use.

Once 16.04 comes out in April, Virtualmin will support that as well.


How do I manually (or automatically) install the current version of virtualmin on my Ubuntu 15.10 server? Or is this not recommended and not possible?

I tried uploading the .deb file on Webmin Module but it expected tar file.

Any clue?


I’d highly recommend using a supported distro/version… it’s very very very hard to get an install working manually.

However, if you really wish to, you can try performing a manual installation using these instructions here: