installing SOAP Library - PHP Conflict

I am trying to install SOAP library on my CENT Os 6 64 bit using Virtualmin by following this tut

I have two php versions installed on my server (5.3 and 5.6)

When I tried to install, I am getting following error

[root@ydomain ~]# yum install php-soap
Loaded plugins: fastestmirror, replace
Setting up Install Process
Loading mirror speeds from cached hostfile

  • base:
  • epel:
  • extras:
  • updates:
  • webtatic:
    Resolving Dependencies
    –> Running transaction check
    —> Package php-soap.x86_64 0:5.3.3-46.el6_6 will be installed
    –> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-soap-5.3.3-46.el6_6.x86_64
    –> Running transaction check
    —> Package php-common.x86_64 0:5.3.3-46.el6_6 will be installed
    –> Processing Conflict: php56w-common-5.6.16-1.w6.x86_64 conflicts php-common < 5.5.0
    –> Finished Dependency Resolution
    Error: php56w-common conflicts with php-common-5.3.3-46.el6_6.x86_64
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Can someone please help me out with this.


I’m unfortunately not too familiar with the repositories you have enabled there. A number of third party repositories can cause problems though.

It sounds like the packages in the third party repository are conflicting with the packages included with CentOS.

You could always talk to the author of the document you’re using, or the maintainer of the repository, about that particular problem.

Alternatively, you could always try the SCL repository, which we like and is better supported within Virtualmin. It’s actually maintained by the CentOS folks and doesn’t have those sort of conflicts.

However, there’s a problem with the current Virtualmin version where it won’t see PHP 5.6 from that repository ATM, due to it using a slightly different path.

i was using webtatic repo and the correct command was

yum install php56-soap

It worked. problem solved.