Installing issue

I am new to linux, as i am a windows person, but recently i have taken an interest into using linux for my webhosting needs.
I have a box, sitting in my rack, its not the best but its an AMD 2400+ 1GB ram, 160GB hdd, NEW os install of Ubuntu 9.10

And, iv been trying to install this software but its not working, im running as root, and doing the following
it does it thing, then after a short 30 seconds or so, it gives an error and wont finish.

I will attach the log file of what i get.

If you tell me to do something, its new to me, so if you would type out the command for whatever it may be.



INFO - 2009-10-30 15:50:44 - Removing Debian apache packages…
DEBUG - 2009-10-30 15:50:44 - Reading
INFO - 2009-10-30 15:50:45 - Installing dependencies using command: /usr/bin/apt-get --config-file apt.conf.noninteractive$
Reading package lists…
Building dependency tree…
Reading state information…
Package webmin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
FATAL - 2009-10-30 15:50:46 - Fatal Error Occurred: Something went wrong during installation: 0
FATAL - 2009-10-30 15:50:46 - Cannot continue installation.
FATAL - 2009-10-30 15:50:46 - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - 2009-10-30 15:50:46 - re-attempted after any problems have been resolved.
FATAL - 2009-10-30 15:50:46 - Removing temporary directory and files.
FATAL - 2009-10-30 15:50:46 - If you are unsure of what went wrong, you may wish to review the log
FATAL - 2009-10-30 15:50:46 - in /root/virtualmin-install.log

Yeah, unfortunately, Ubuntu 9.10 isn’t one of the supported distros for the Virtualmin installer.

The supported distros are listed here:

Ubuntu 8.04 is the most recent supported distribution – it’s an “LTS” release, so it’ll be supported for 5 years, making it a great server OS.


Well thing is, i had 8.04, and i got the same error…
So what am i doing wrong?

Well, it’s hard to say exactly without seeing the specific errors on the supported distro… on 8.04, it typically works out of the box with the

Are you by chance using a non-standard software repository?

We’ve occasionally seen third party software repositories with conflicting packages.

How did you go about installing Ubuntu, is that something you did, or do you have a provider who did it for you?

What do you see if you run this command:

grep ‘^[^# ]’ /etc/apt/sources.list

I am having similar issues with a stock Debian 5.0 install. I have made sure to be using the default repos and its completely fresh. By chance is one of the virtualmin repos added during the script install no longer correct?

Interesting note for you, when I add the repo manually before the install and import the key everything worked without a problem.

Add this to repos /etc/apt/sources.list:
deb virtualmin-universal main

Then add the key:
wget --quiet
apt-key add RPM-GPG-KEY-virtualmin

Hrm, I’d kind of like to see what your /root/virtualmin-install.log file looks like when the install doesn’t work.

There may be an error tucked away in there that describes what’s going on.

I don’t suppose you happened to make a copy of that before attempting the install again? :slight_smile:


I’m doing it again right now, tried another panel and am going back to virtualmin. Will let you know.

EDIT: Weird, I just redownloaded the script, and everything worked fine.

EDIT2:JK, just reinstalled and it does the same thing: here is the log

I’m gonna run some test installs on Ubuntu and Debian to see what’s going on.

But, I will note that it definitely is not expected to work (at all, under any circumstances) on Ubuntu 9.04. So, don’t waste your time even trying it there. Not to mention the lifecycle of non-LTS releases is way too short for sane use on a server.

OK, so I just ran a test install of Virtualmin GPL on a fresh Ubuntu 8.04LTS system…and it went off without a hitch. No problems at all.

I’m stumped. I don’t know what’s going wrong in the cases mentioned above. I’ll try on Debian 5 tomorrow, but I don’t expect any problems.

Some things I’d suggest folks try:

  1. Make sure your system is freshly installed. This means you haven’t enabled third party repositories, installed non-OS packages, installed “security” or “hardening” scripts, etc. Updating the system from the standard OS repository is recommended. Because dependencies can change over time, and the install script installs a huge number of packages, updating helps make sure that any old packages that might conflict with new ones won’t be around to cause trouble. This is not so much an issue on RPM/yum systems, but apt-get is pretty darned sensitive, and sometimes has a hard time resolving complex dependency chains.

  2. Make sure you have a fully qualified domain name configured on your system.

  3. Make sure networking and the package manager is working. This can be reasonably assured by performing the apt-get upgrade I suggested in 1.

The logging doesn’t work very well on Ubuntu/Debian systems, as capturing apt-get output is difficult. So, you may have to watch the live output as the install is running for clues about why it might be failing.