Installing EPEL 7 release package: [ERROR] Failed with error: 1

Hey guys I am having an issue installing Virtualmin on RHEL 7.9. I have installed it before with no problems, but all of a sudden this same issue keeps coming up, even though I am doing fresh installs.
This is the error message that I am getting, but it does not really explain what the problem is. I have tried removing the EPEL7 and re-adding but with no luck

If there is an EPEL release package already installed, you can comment out the line that installs it in install.sh (it’s roughly here: virtualmin-install/virtualmin-install.sh at ec5af73fdafd7f19a8956b076531e54749e02a75 · virtualmin/virtualmin-install · GitHub ), on line 813, if you have the current script.

Just put a # in front of the line and it’ll be skipped.

I guess we aren’t capturing the case where there is already a newer version of the EPEL release installed…I’ve never seen that happen and I can’t figure out why it’d happen for you. It shouldn’t, unless it was installed from some unusual source or you’ve got the updates repo disabled or something.

I don’t have an RHEL system handy to test on, but unless there are other issues, that one-line change should get you through it.

Please let us know if @Joe’s suggestion worked for you @joe904?