Installed phpMyAdmin via Virtualmin - now I get 1045 Cannot login


I previously manually installed phpMyAdmin under one of my domains on my virtualmin server. This was the only PMA URL we used to log in as various other domain owners.

After doing this whole PHP Fix symbolic links, etc crap… it broke. Now we’re unable to login to PMA via browser. On ssh, mysql -u style authentication works and logs us in, but just not remotely. Tried PMA, and tried a windows desktop software - and nada.

So, I reinstalled pma via Virtualmin script this time under another domain hoping that a fresh copy might solve problems - and nope. It’s the same old thing.

After frantically googling for answers, I have now given up. There’s nothing in the logs (access_log, error_log, mysql.log)
Somebody PLEASE help.


So here’s what happened:
A couple days ago, my server was hacked via password bruteforce and index.php had malicious code injected (long story, Google blacklisted us, a lot of our domains started invisibly letting users download stuff from another domain, etc).

Anyway, this code used eval, base64_decode and gzinflate to encrypt the code. So, I decided to just block these functions:

disable_functions = eval, base64_decode, gzinflate

I just realized that this might be why pma wasn’t logging in. And true enough, through trial and error, figured out that base64_decode is an important function for phpMyAdmin to function. Removed that, restarted httpd, and voila… phpMyAdmin is back to connection on both domains.