Installed module not being moved from unused


I have two new installs one on Debian (Major Problems get this one working) and on a ubunto 8 server. Both of these are not moving installed module such as dovecot, mysql, procmail, spamassassin to the sever list. Both of these installs were done by the setup script as the apt-get install failed.

How dose webmin determine if the module is installed and move it to the right place? When it fails to do so how do you move them manually?

Thanks Shanta

Hey there,

When you log into Virtualmin, then click “Webmin”, you’ll see a link all the way at the bottom labeled “Refresh Modules”.

Do those modules move to the appropriate section after you click that?

Just clicked it.

There is no change in the list.

They are still in unused.


I tried again today.

This time the script gave me a message that it found x of usable module and x number of unused modules.

The list however remained unchanged.

I refreshed the frame and all moved to server except spamassasin.

Any ideas on why this would not have moved as I have it install and working.

It seems though that it crashed MySQL I had to restart it after the process.


im seeing the same problem on 2 new installs running on Debian

scratch that, clicking "Refresh Modules" fixed it for me :slight_smile: