Installation Problem?

I am fairly new to the Webmin application and had some questions. I am currently running Webmin on an AIX 5.3 box. I tried reloading the application a few times and it does work, the installation works fine. The problem that I am having is when I go to the http://hostname:1000 it shows the login page and I am able to login but the only information it shows is the system information and a logout button. The menu with all the modules does not display at all. I have tried reload and restarting services though it seems to have no effect.

I have spend some time trying to find similar issues in forums and thread but have not found any related problems.

Maybe someone has seen this and found some similar issues.


:)<br><br>Post edited by: ronald, at: 2008/06/05 11:18

It is a support OS for Webmin. IBM AIX 5.3

Installation layout:
Install path: /webmin/bin
Log path: /webmin/logs
Config path: /webmin/config

Generated Logs:
hostname # ls
blocked miniserv.log sessiondb.dir
miniserv.error sessiondb.pag

This is the only error I could find in the logs:
techie # more miniserv.error
[05/Jun/2008:08:36:38 -0500] started
[05/Jun/2008:08:36:38 -0500] Perl module Authen::PAM needed for PAM is not installed : Can’t locate Authen/ in @INC (@INC contains: /webmin/bin /usr/opt/perl5/lib/5.8.2/aix-thread-multi /usr/opt/perl5/lib/5.8.2 /usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi /usr/opt/perl5/lib/site_perl/5.8.2 /usr/opt/perl5/lib/site_perl .) at (eval 4) line 1.
BEGIN failed–compilation aborted at (eval 4) line 1.

Any thoughts? Thanks in advance!

Actually, Ronald, Webmin is supported on AIX. And nearly every other UNIX/Linux in existence or that has existed in the past ten years. :wink:

Virtualmin is a little trickier, but Webmin ought to work fine.

The PAM error is harmless. PAM is only needed if you’re authenticating to NIS or LDAP.

I suspect something is messy in your root or admin acl file. It sounds like your user doesn’t have access to any modules. Look at the webmin.acl file in the Webmin configuration directory…see if the root: line has a bunch of stuff in it, or if it is empty. Empty would be what I would expect to see with your problem description…but it ought to look like:

root: backup-config change-user translator usermin virtualmin-notes server-manager webminlog webmin servers acl bacula-backup init passwd quota mount fsdump ldap-client ldap-useradmin logrotate mailcap mon pam proc at cron sentry software inittab desktop man syslog useradmin virtualmin-init security-updates virtualmin-awstats apache bind8 pserver dhcpd dovecot fetchmail frox jabber majordomo mysql openslp postfix postgresql proftpd procmail qmailadmin mailboxes sshd samba sendmail spam sarg squid virtualmin-google-analytics virtualmin-mailman virtualmin-svn virtual-server virtual-server-gpl wuftpd webalizer adsl-client bandwidth ipsec krb5 firewall exports nis net nettools pap ppp-client pptp-client pptp-server stunnel shorewall virtualmin-registrar idmapd filter burner grub raid lvm fdisk lpadmin smart-status time vgetty cluster-passwd cluster-copy cluster-cron cluster-shell cluster-software cluster-usermin cluster-useradmin cluster-webmin cfengine heartbeat shell custom extjs file tunnel phpini php-pear cpan htaccess-htpasswd ruby-gems telnet status updown virtualmin-dav virtualmin-htpasswd virtualmin-slavedns virtual-server-svn dfsadmin dnsadmin inetd ipfilter ipfw lilo smf syslog-ng xinetd virtualmin-oracle virtualmin-mysqluser virtualmin-signup exim ldap-server

(All one line.)

If you don’t have a big list of modules like that, then just copy-paste mine in and save it, and restart Webmin. If you do already have that (or close enough–mine has quite a few additional modules that yours won’t have), then I’m probably stumped. We’ll need to look a bit deeper.

after installation of a minimum OS did you do a update?
Also I would solve the module Authen::PAM issues as it seem to need it badly lol

also it seem to be better installing the instead of install it manually if that where the case.

lol all my posts are getting confused.
yes I had a look at the webmin page later on and saw a huge list of Os’s being supported by webmin.

Im too much into virtualmin i guess :slight_smile:

Thanks for the responses guys.

I tried adding in those webmin.acl entries cause they were not there. Though after a restart of services, then a reboot in case I missed something they still don’t show up.

I just reinstalled this not long ago so no OS/Tech Level/Fix packs have been loaded. Nothing seems to be causing problems though OS wise. I did use the for the install and it found no errors with perl or any other dependancies.

I am baffled as to what could be causing the problems.

One other note is that the webmin.acl file that I am editing is in my /webmin/config/webmin.acl if that is in fact where it should be located. I could not find another file in the filesystem called webmin.acl

Also I would solve the module Authen::PAM issues as it seem to need it badly lol

It doesn’t need it for most systems. PAM is used for authenticating to NIS or LDAP, otherwise it falls back to authenticating to shadow without problem.

Oh my gosh!! I got it guys with your help with the acl file. The problem was the user entered in the setup was not root it was admin. Could have been the problem.

I appreciate all the help guys!!

One other note is that the webmin.acl file that I am editing is in my /webmin/config/webmin.acl if that is in fact where it should be located. I could not find another file in the filesystem called webmin.acl

You would know better than us, though the default is /etc/webmin. But the script will allow you to alter any of the directories where Webmin resides. Some command line tools within Webmin might not handle directories other than /etc/webmin for the configuration (you’d just have to set a couple of environment variables), but nothing else should have trouble. And I’m pretty sure this isn’t caused by configuration being in a non-default location.

The state of your underlying system also shouldn’t have any impact on this particular problem–you might need to update some of Webmin’s module configuration to suit your system, but that is an issue well past where we are right now. :wink:

Are you actually logging into Webmin as root or some other user?