Installation failed on fresh Ubuntu 22.04 system

OS type and version - Ubuntu 22.04.1 LTS (5.15.0-52-generic x86_64)
Webmin version - N/A
Virtualmin version - N/A
Related packages - N/A

Tried installing Virtualmin using the install script (LEMP + Minimal) on a fresh Ubuntu 22.04 system and Phase 1 of the installation was successful but on Phase 2, the following error(s) pops up and the installation stops. What could be the cause for this?

[INFO] Started installation log in /root/virtualmin-install.log
▣◻◻ Phase 1 of 3: Setup
Downloading Virtualmin 7 key                                            [  ✔  ]
Installing Virtualmin 7 key                                             [  ✔  ]
Downloading Webmin key                                                  [  ✔  ]
Installing Webmin key                                                   [  ✔  ]
Downloading repository metadata                                         [  ✔  ]
Enabling universe repositories, if not already available                [  ✔  ]
Disabling cdrom: repositories                                           [  ✔  ]
Cleaning up software repo metadata                                      [  ✔  ]

▣▣◻ Phase 2 of 3: Installation
Checking and installing system packages updates                         [  ✔  ]
Installing Virtualmin 7 and all related packages                        [ERROR] Failed with error: 100
[  ✘  ]

[ERROR] Something went wrong. Exiting.
[ERROR] The last few log entries were:
needrestart is being skipped since dpkg has failed
E: Sub-process /usr/bin/dpkg returned an error code (1)

@Joe @Ilia @Jamie @Eric


This issue is certainly not related to Virtualmin repos or install script.

You can look at the virtualmin-install.log file for more details. There is something wrong with your Ubuntu installation/package manager. You can either figure this out and fix it or spin up a new instance with a different provider. I can personally recommend Linode.

If you want to debug the current instance, which eventually might take more time, I would start from running apt-get clean && apt-get update && apt-get install nginx-full to see what you get.

1 Like

Also, double check if you are really using Virtualmin version 7.0.0.

I think it’s most probably related to this since I’m using this script available in the downloads page:

I’ll check out the virtualmin-install.log and see if I can figure out how to fix this.

I assure you that the problem is not on our end!

Yes. I was referring to the Ubuntu package manager. I’ll talk to the server provider and see if there is something they could do. Thanks for the help Ilia

So since 20.04 was working fine for me, I ended up installing Ubuntu 20.04 LTS on the server and then manually upgrade it to 22.04 after which I tried installing VirtualMin on it again and everything works beautifully now.

I’ll drop the server provider a message and let them know that the package manager of their 22.04 OS has issues.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.