Install via install script on ubuntu-minimal 18.04 :Unable to open /etc/network/interfaces

Hi folks,
im testing a bit with virtualmin. I will run a own server for the next years, so it would be great to start with the new ubuntu 18.04 so i have plenty of time before the next big server update is needed. I have read that the new install script schould work with ubuntu 18.04 but i got the error “Unable to open /etc/network/interfaces Unable” when is trying to accomplish this step" [9/23] Configuring Net ". Maybe someone has some nice hint for me. I tried the installation twice both with fresh installations.

Thx a lot for reading and helping

Disclaimer: I am not with virtualmin tech support.

  1. It appears that virtualmin does not yet (May 2018) support Ubuntu 18.04 (since the networking configuration has been changed from /etc/network/interfaces to “netpland”)

  2. If you are setting up a new server now, you might want to consider the following:

a) install Ubuntu 16.04 (which will be supported until 2021) and

b) then in 2021 install Ubuntu 20.04 (which will have a year of testing by 2021 and hopefully be more stable)

Ubuntu Server LTS releases are not considered “ready for production use” until the July after the April release (e.g. 18.04.1).

Another option is to install Debian 9.4 which will be supported until 2022

That’s a new one. I didn’t see that on my test installs. I’ll have to do some poking around to see why it worked on my test systems, and whether I should just make it work the old way, or add support for whatever the new thing is. Apparently the old way is still around in some form, since my test machines at Vultr completed this step without issue.

OK, so the VM at Vultr I was testing on does revert back to the old way of handling network interfaces, so I need to poke around some to learn how netplan works. It seems related to NetworkManager, which I’m not very fond of on servers, but I’m doing more research to figure out what we ought to be doing here, whether it’s reverting to the old “interfaces” file or adding some support for netplan.

Here’s some discussion of it at StackExchange:

On one hand, it seems like a lot of folks share my dislike of NetworkManager on servers, but on the other hand there does appear to be a configuration intended for servers, which may make it work OK. I’ll do some testing.

If anyone here knows more about the change, and why we might want to choose one way or the other forward, feel free to chime in.

In the meantime, if you’re comfortable working at this relatively low-level, one of the links above includes the method for reverting back to the old way of doing things (which will make the installer work, though I’m also looking into some procmail-wrapper related issues, so there’s still a bit of pain in getting Virtualmin running nicely on Ubuntu 18.04). I think at this stage, running Virtualmin on 18.04 should be considered something requiring intermediate Linux knowledge (you’re gonna have to know how to deal with configuring some things manually because the installer is still messing up a few things and I’m still working out whether it’s because we’re detecting things wrong, not installing all the right dependencies, or just looking in the wrong files for making changes, etc.).

OK, after talking it over with Jamie, he’s going to try to implement some support for netplan into Webmin over the next couple of weeks. So, I think I’m not going to add reverting to the old way into the installer (messing with peoples networking in an automated fashion isn’t something I’m really comfortable with, anyway, as it could potentially disconnect the network session and maybe even break networking, if I got something wrong in the conversion, which seems likely with all of the pieces and how complex some of them can be).

So, for the time being, to install on Ubuntu 18.04 you’ll need to revert to the old way before running Seems like some VMs already have it this way (since this is the first report of this problem I’ve seen and there have been a few other installations on 18.04 by other users who didn’t run into this). And, it may even make sense to do so on servers, regardless of whether Virtualmin and Webmin support the new way. Certainly the benefits of NetworkManager/networkd/netpland are most obvious in laptops, where networks change regularly due to mobility and maybe based on which user is logged in.

Thx a lot for the efforts and quick replies.
I will look how to revert the /etc/network/interfaces to the old way. Thx for the usfull links

Have a nice day

Update: i will follow @jimdunn advice :slight_smile:


I had the same issue and fixed it by :
touch /etc/network/interfaces

And i restarted the install which runned fine

I had a similar problem, though not exactly because of netplan. I installed a new server on a leased kimsufi server (kimsufi is a low cost substitute of OVH) their system install template uses neither ifupdown nor netplan, but config files in the systemd structure in /etc/systemd/network/50-default-network and /etc/systemd/network/ It took me a while to figure out what they did :slight_smile:

So what i did was to just create the /etc/network interface like this :

# The loopback network interface auto lo iface lo inet loopback

The primary network interface

auto enp1s0
iface enp1s0 inet static
address #found with ifconfig
netmask #found with ifconfig
network # found with route-n destination address
broadcast #found with ifconfig
gateway # found with route-n gateway address
iface enp1s0 inet6 static
address xxx:xxxx:xxxx:xxxx::x #found with ifconfig
netmask 128 #found with ifconfig (prefixlen value)

All the relevant info can be found with ifconfig and route -n (for the gateway and network adresses) (or in my case in the 2 systemd config files)

That made webmin happy and I could configure my firewall, I didn’t even have to replace the network subsystem with ifupdown.