fatal error! 3.47 not found

Hi there,

I just tried running the script on a clean copy of Debian Etch and ran into a fatal error. It seems like you guys are in the middle of rolling out an update because the script is trying to grab virtualmin 3.47 which, are far as I can tell, hasn’t been announced/released:

Failed to fetch 403 forbidden.

I checked the site manually myself and at the time of my writing the file exists and is returning a 403. I am guessing that things are our of sync between how the script determines that latest version to download and the the actual availability of 3.47

Just giving you guys a heads up. Let me know when it is fixed.

Good thing I was just testing it on a virtual machine!


Same problem here. This is the first time I am using the script. Is this working as designed, or is there something else up… like permission problems on the file? Or something else I need to do from my side?


Edit: Also, in case this helps, this is for Debian 4.0. Thanks.<br><br>Post edited by: Ray, at: 2007/10/14 21:34

Something is broken in my build/deploy scripts, and I’m having a hard time finding it–it’s fixed for now, but I’ll have to find the root cause to prevent it from happening again.

I think I’ve fixed it for good now (I had copied the GPL version into my local repo from a system using the root account, rather than the joe account, so permissions were botched).

Holy… uhm, that was fast, Joe. Thanks, your response time is absolutely amazing.

I did a ./ --fix-missing just as you posted and it installed fine.