Install script worked great on Raspberry pi4 4gb

Just wanted to post that the install script worked great with a fresh ubuntu server 20.04.03

1 Like

Well, since Ubuntu 20.04 is a Virtualmin preferred, supported OS, that makes sense.

Correct, but a different architecture. Which gave me the impression that it would fail. But worked great!

Hey @zylith, welcome… can you give us more details? I’m also surprised it worked. Did you use Ubuntu 20.04.3 armhf or armv7 ???

hostnamectl says arm64- I downloaded it from ubuntu arm page. If there is a command you want me to run and post the output I would be more than happy to.

It did not work great. You’re missing procmail-wrapper (which is needed for processing and delivery of mail). Other distros on ARM would be missing a couple of packages, as well.

Our listed distros and operating systems are linked from the download page.

procmail-wrapper source is included in the virtualmin-gpl github repo, so you can build it yourself, if you like. Install it setuid root.

1 Like

That’s pretty cool. I’d be curious to see performance under various loads!

+1 for that. I would be too.

YUp.

Would be nice to know in which combination for what purpose you use the PI4 and Virtualmin.

If succes maybe a separate topic Raspberry here on forum or somewhere else?

For now i only can think of:
Testing things, nextcloud, NAS, Firewall, Mediacentre, Ebook management, CAMS (security) and ofcourse lot of IOT related.

(Then to know the Support time from Virtualmin team is not endless, so self supported by those Forumusers together, and for those wo are satisfied and have some money over to spend to Virtualmin team then.)

1 Like

Yeah I use it to host 2 sites- very low volume sites. And nextcloud right now. I am trying to get bitwarden on it but I can’t seem to figure out the apache files.

1 Like