Install failed when i reinstalled virtualmin through ssh

**Operating system:**linux
**OS version:**centos8
Hello ,today i have tried to reinstall os and install virtualmin but unfortunately error came even after trying several times, it has shown that the licence provided by software.virtualmin is not trustable.but i have installed several times before through putty by just applying two commands (wget & sudo /bin/sh
if any one experienced this issue kindly help me out to get through it .
server: Vps
from :contabo
os: Centos8
preinstalled in server : LAMP
ssh : putty windows 64bit
tried to install: virtualmin gpl

We can’t help you without you posting the actual error you got.

Tell me what I need to provide , because im not skilled in coding .

I rebooted the server and installed centos8 and Lamp from default installer provided by contabo .then I opened ssh Putty (windows 64 bit) and remote logged in to my server then run the downloader command “wget http ://software” and “sudo /bin/sh” and error came like the certificate is not trusted and cannot install , I tried doing several times rebooting again and again . but same happened . But before this I have done this process ,it worked well , but I habe no clue whats now .

I have the same issue I think it’s because defaults to http and not https

How to sort this out ?

but it was working fine till 2 days back

I think the easiest way to sort this out is to run package upgrade command, like:

  • CentOS 7/RHEL 7:

    yum clean all && yum update
  • CentOS 8/RHEL 8:

    dnf clean all && dnf update
  • Debian/Ubuntu:

    apt-get clean && apt-get update && apt-get upgrade

Additionally make sure that the package ca-certificates is installed and most importantly updated.

where do i need to place this command ?
before running download virtualmin command or this itself will automatically install virtualmin

in the linux terminal

Currently there seems to be an issue with intermediate certificate on our side. @Joe is working on fixing it.

1 Like

so it will work like before once it is corrected? because it was working well till yesterday

sure ill try out now , is it working for you?

Thank you for the update. @Joe do you have any ETA on this? Thank you!

is it working for anyone now? as like normal procedure

Here’s a workaround I used last night when getting the same error on a new install that I thought had to do with Oracle. It’s not advice. It’s just something I did that worked.

openssl s_client -showcerts -connect

Copied the certificate information as a file software2-virtualmin-com.pem into /etc/pki/ca-trust/source/anchors .

Ran update-ca-trust .

This was not on a production machine. I’m doing some experimenting. On a production server, you’re probably better off waiting until @Joe fixes it. But if people will die if you don’t get the server running right now, it should work.


1 Like

The issue has been sorted out.

Thanks for the heads up!

1 Like