Install fail Missing Log::Log4perl::Appender::File

Operating system: CentOS
OS version: 8

I ran the automated install, it fails on Phase 3 with this error:

ERROR: can't load appenderclass 'Log::Log4perl::Appender::File'
Can't locate File/ in @INC (you may need to install the File::Path module) (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at /usr/share/perl5/vendor_perl/Log/Log4perl/Appender/ line 11.

I installed the perl-Log-Log4perl.noarch package

The module it can’t find is File::Path, not Log4perl. Package is named perl-File-Path, I guess, though this is supposed to be a core module.

Yes thanks, I figured that out and then it worked.
I would have thought that the automated install script would have looked for it and installed it.
I was starting from a minimal CentOS install.

Yes, it’s apparently a missing dependency that we need to add to our yum group. But…Perl core modules should be included in the standard Perl…so, I think Red Hat are the guilty parties here. I guess they broke Perl in order to allow upgrading individual core modules, since the Perl in Red Hat/CentOS is historically ancient (it was literally a decade old in the case of RHEL/CentOS 6 when it reached EOL, and it was like three or four years old when they branched 6…there’s some truly diabolical Perl hatred at Red Hat). So, there’s no winning with Perl on RHEL/CentOS, they’re just gonna make it suck one way or another.

Anyway, I’ve added it to the deps for future releases. I don’t have time to verify/test and push it out to repos right now, so it may be a while before it’s automatic.

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.