Indico automatic redirect after install other virtualhost with virtualmin

Hi,
I installed a conference system using Indico and using apache2, then I installed virtualmin with ubuntu 18.04

indico runs very well and has been using it for a week with virtualmin, the problem came when I created a new virtualhost on virtualmin, when I created a new virtulmin, my old web(indico) would redirect to the web I just created using virtualmin.

virtualhost indico :

ServerName indico.domain
DocumentRoot “/var/empty/apache”
Protocols h2 http/1.1
SSLEngine on
SSLCertificateFile /home/indico.domain/ssl.cert
SSLCertificateKeyFile /home/indico.domain/ssl.key
SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
SSLCACertificateFile /home/indico.domain/ssl.ca
XSendFile on
XSendFilePath /opt/indico
CustomLog /opt/indico/log/apache/access.log combined
ErrorLog /opt/indico/log/apache/error.log
LogLevel error
ServerSignature Off

AddOutputFilterByType BROTLI_COMPRESS text/html text/plain text/xml text/css text/javascript application/x-javascript application/javascript application/json application/x-font-ttf application/vnd.ms-fontobject image/x-icon

<If “%{HTTP_HOST} != ‘indicodomain’”>
Redirect 301 / indicodomain/

AliasMatch “^/(images|fonts)(.)/(.+?)(__v[0-9a-f]+)?.([^.]+)$" “/opt/indico/web/static/$1$2/$3.$5”
AliasMatch "^/(css|dist|images|fonts)/(.
)$” “/opt/indico/web/static/$1/$2”
Alias /robots.txt /opt/indico/web/static/robots.txt
SetEnv UWSGI_SCHEME https
ProxyPass / uwsgi://127.0.0.1:8008/
<Directory /opt/indico>
AllowOverride None
Require all granted
</Directory .>

Here is another virtualhost create by virtualmin

SuexecUserGroup “#1003” “#1003
ServerName ohterdomain
ServerAlias ww.ohterdomain
ServerAlias mail.ohterdomain
ServerAlias webmail.ohterdomain
ServerAlias admin.ohterdomain
DocumentRoot /home/ohterdomain/public_html
ErrorLog /var/log/virtualmin/ohterdomain_error_log
CustomLog /var/log/virtualmin/ohterdomain_access_log combined
ScriptAlias /cgi-bin/ /home/ohterdomain/cgi-bin/
DirectoryIndex index.php index.php4 index.php5 index.htm index.html
<Directory /home/ohterdomain/public_html>
Options -Indexes +IncludesNOEXEC +SymLinksIfOwnerMatch +ExecCGI
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted
AddType application/x-httpd-php .php
AddHandler fcgid-script .php
AddHandler fcgid-script .php7.4
FCGIWrapper /home/ohterdomain/fcgi-bin/php7.4.fcgi .php
FCGIWrapper /home/ohterdomain/fcgi-bin/php7.4.fcgi .php7.4

<Directory /home/ohterdomain/cgi-bin>
allow from all
AllowOverride All Options=ExecCGI,Includes,IncludesNOEXEC,Indexes,MultiViews,SymLinksIfOwnerMatch
Require all granted

RewriteEngine on
RewriteCond %{HTTP_HOST} =webmail.ohterdomain
RewriteRule ^(?!/.well-known)(.) ohterdomain:20000/ [R]
RewriteCond %{HTTP_HOST} =admin.ohterdomain
RewriteRule ^(?!/.well-known)(.
) ohterdomain:9191/ [R]
RemoveHandler .php
RemoveHandler .php7.4
FcgidMaxRequestLen 1073741824
SSLEngine on
SSLCertificateFile /home/ohterdomain/sslcert
SSLCertificateKeyFile /home/ohterdomain/sslkey
SSLProtocol all -SSLv2 -SSLv3 -TLSv1 -TLSv1.1
SSLCACertificateFile /home/ohterdomain/sslca

after i do installation , indico will redirect to new domain page :

when I create a new virtualhost, the indico system will always also point to the new virtualhost, i tried with 3 different domainm, but still redirect , how do I solve this problem?

regards
Ghazi

@ghazi always install virtualmin 1st after updating your system then do the rest… I suggest you to trash system and start over…