Increase Mysql memory?

I’m getting this error when trying to import a database file in phpmyadmin

Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 13937832 bytes) in /usr/share/phpmyadmin/libraries/unzip.lib.php on line 325.

I edited the php.ini file and increased the memory to 32M but still the same error message.

How to I solve this? I also don’t understand how 13mb can exhaust 16mb of memory?

I’m assuming it will be in the mysql settings somewhere ?

Well, I suspect it means it was trying to allocate 13MB more, rather than 13MB total.

So yeah, what I would recommend is bumping up the “memory_limit” in your php.ini. If you’re using Virtualmin Pro, you’ll need to make sure you’re changing the php.ini for your domain (in $HOME/etc/php.ini), not the system one in /etc.


Ok got that fixed now. I was editing the wrong php.ini file.


If you have a new topic, you should start a new thread :slight_smile:

However, after changing the php.ini file, you may need to restart Apache.


Got it. I thought it was pretty related…they seem to go together like chocolate and peanut butter :slight_smile: