include ltd in new virtual host home directory

if I create 2 virtual hosts, first, second it will create the folders /home/example and /home/ respecivly.

I would like to force the folder to always include the ltd (is that the right term) so the folders will always be,, etc.

I may be OCD but if I KNOW what the folder is, I don’t have to ls it.

after trying out many control panels, webmin/virtualmin is awesome in everyway! THANKS!

There’s a configuration option for that. Go to Virtualmin -> System Settings -> Defaults for New Domains and in the field “Home subdirectory”, switch to “From template” and enter “$DOM” as template. Then it will always use the full domain name for the home directory, as opposed to the name of the administrative user.

Oh you’re right, I forgot the “Virtualmin Configuration” part in the path. :slight_smile: Glad you found it!

Thanks Locutus! I had to do a little digging but you put me in the right place. I was looking in System Settings -> Server Templates . . . it’s not there

For me it was in System Settings -> virtualmin Configuration -> Defaults for new domains
(Webmin version 1.660 Virtualmin version 4.03.gpl GPL)

Thanks again!